View Full Version : Cant launch ACR

12-05-2011, 02:00 PM
Hi all,

This morning i recieved my PC version of assassins creed revelations.

now i have installed the game (no problem)

autopatch downloaded patch 1.01 (no problem)

but when i click on PLAY, the game doesnt start.

i see a flah of autopatch, and then it desappears again.

My computer is up-to-date (play a lot of games, ACB was no problem, Far cry 2, COD MW3 no problem either)

reinstalled the game already.

any help please?

Thanks in advance..

12-06-2011, 01:54 AM
okay, so now i changed some things in my PC so now it has changed some settings and stuff.

now when i run the game a window pops up saying

"cannot load recource files. reinstalling the game may solve the problem"

12-06-2011, 02:09 AM
Hi There,

Please contact Ubisoft support for help and advice.

you can contact them via the links in my signature.

12-06-2011, 08:02 AM

i contacted them but had no response.

fixed the problem myself though.

unistall the ubisoft gamelauncher you had and reinstal the one on the disk. worked for me anyway.