View Full Version : Display Resolution Problem

07-11-2006, 07:07 PM
I just tried the high res tweak, and ran into a problem. I'm running XP SP2, and installed the MS Compatability Tool Kit, which is required for SP2 users.

I unzipped the res dll. to my SHIII directory, and ran the compatability program as directed to set up a profile for SHIII. During the setup process, you could run a "test" to see if the tweak has worked. well, the test ran great, and the game has never looked better. After exiting the game, I finished the Compatability setup, and exited the program.

The problem is, when I try to run the game now either by useing FS Autostart, or by clicking the game's desktop icon, I get a CTD, with the message that "SHIII has encountered a problem, and needs to shut down". What went wrong? Any help is appreciated. I'm running RUB1.45, if that means anything. Thanks again.

07-11-2006, 07:17 PM
try going into the d3d9 config file and backing off the resoulition http://forums.ubi.com/images/smilies/shady.gif

07-11-2006, 09:29 PM
Originally posted by Fish40:
...well, the test ran great, and the game has never looked better...
doesn't make sense that it worked and now it won't. maybe you missed a step or something.

after you saved your setup, did you install the database? open up the compatability administrator and verify sh3 exists under installed databases.
- if yes, maybe delete and try again.
- if you don't see "installed databases" above "custom databases" it never got installed.

like bunkerratt mentions, check your d3d9.cfg file and set it at a resolution you know works.

07-12-2006, 03:12 AM
Thanks for the tips guys. Going over the SHIII setup again in the Compatability administrator.

Posted Tue July 11 2006 18:17
try going into the d3d9 config file and backing off the resoulition

Where exactly is this file? I found a file of this description in the SHIII directory, but could not acess it. I looked in the confg. file, but there was'nt any way to change settings. If there is a way to do this, please enlighten me. Thanks again for your help.

07-12-2006, 06:45 AM
did you download dx9res10.zip?

1. unzip
2. copy d3d9.dll and d3d9.cfg to sh3 root directory.
3. edit d3d9.cfg with notepad.
-right click on file name. open with notepad.

07-12-2006, 03:38 PM
I know what the problem is, but am unsure how to solve. Let me explain: Zoinks, you correct in that the database was not saved. I follow the instrucions to the letter, and get to the part where you click the finish button, then click save, and name the save SH3. After this step, you're supposed to click on "file", and install.

The confusion comes in after I click the save, and name the save SH3. A "Save Data Base:SH3" window opens. On the top of the window, there is a smaller window with a dropdown menue. The heading of this window is "Save In", and SH3 is written in the window. At the bottom are two other windows. The first is "File Name", which is blank. The second is "Save As Type", where AppCompat Database(.sdb) is written in.

It seems I need to enter a file name in the blank window, because if I don't, and I try to install the database, it tells me I need to save the database first. I'm unsure of what file nae to enter in the window. I'm sorry if this sounds a bit confusing, but I'm close to success and just need alittle more help. Thanks for your time.

07-12-2006, 03:54 PM
ya, i was confused about that, too. that's the only part of the wiki that isn't dead on.

its like you have to save twice. i just entered SH3 both times not worrying about the file extensions. don't mess with the pull down, just fill in the new name...can't describe this better.

07-12-2006, 04:06 PM
SUCCESS!!!! Thanks a bunch man. http://forums.ubi.com/images/smilies/11.gif Time to sink some ships in high res glory!

07-12-2006, 04:33 PM

07-14-2006, 11:21 AM
cool...it does look great at higher res .and yes ..the wiki could use a rework on the install steps...i thought about taking a few screenies of each step of the install and posting it as a thread ???..but that would involve getting the crayon thing going in paint and making circles and arrows and things on the screenies..but we should build a better install guide for this issue.. http://forums.ubi.com/images/smilies/typing.gif