View Full Version : Assertion starting Single Player

07-02-2009, 03:08 AM
I get the following assertions trying to run the game via Steam.

My PC is a Dual-Quad Xeon @ 2.8 GHz (8 Cores)
Running Vista x64 Ultimate
8GB of RAM
XFX HD 4870 1GB

Any Help would be appreciated as I really want to play.

Assertion message
Assertion failed !!! =8-O
c:\AUTOBUILD\ChromeEngine4\engine\Physics\Ode\ODEM anager.cpp(1191) :

Assertion message
Assertion failed !!! =8-O
c:\AUTOBUILD\ChromeEngine4\engine\Physics\Ode\Phys icsTypes\ODEPhysics.cpp(10878) :
Condition: thread_id < MAX_SIMULTANEOUS_THREADS
Info: ERROR! [CODEPhysics::Ge****erCurrentObjectsFromCache] number of threads greater than MAX_SIMULTANEOUS_THREADS set in CODETools
Press Abort to close the application
Press Retry to debug the application
Press Ignore to proceed with execution

07-03-2009, 04:50 AM
I'm getting the same error, any help would be much appreciated.

Intel Xeon 8 Core
XP Pro SP2
ATI Radeon 4870

07-03-2009, 09:58 AM
I'm too
Intel Xeonn Dual Quad core E5420 2.5GHz
Windows Vista 64 Ultimate
Creative Elite Pro

07-03-2009, 04:48 PM
problem seems to be caused by multiple multicore proccessors http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif Try to use the windows command msconfig to limit the number of cores to use to 4.

To do so, open the start menu, click on Run,type in msconfig and click on OK. In the upcoming window click on BOOT.ini, then on 'Advanced Options'. Adjust /NUMPROC and restart to enable changes. This is how it worked for me, however this page (http://en.kioskea.net/faq/sujet-616-multicore-cpu-how-to-disable-a-core) describes it slightly different.


07-03-2009, 04:59 PM
Turning off half of the computing power of my machine to just run one game seems a bit extreme. Perhaps, there is a command line parameter I can pass to the game to limit the number of cores it sees.

Or better yet, they can fix the code that should have been tested in the first place.

07-04-2009, 03:38 AM
Oh no. I have 32 cores. Will I be able to run the game?

You guys have Core Spam in your rigs! http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

07-05-2009, 03:45 PM
Getting this same error too. Anyone find a solution yet?

Systems is:
Dual Quad-Core Xeon E5410
Vista x64 Ultimate
NVidia GeForce GTX 280

I agree, turning off cores to run one game is not acceptable.

07-05-2009, 11:49 PM
I have the same error.
Should I be looking to return the game to the shop or should I hold out hopes we will get a fix for this in the near future?

System is:
Dual Quad-Core Xeon E5420 2.5GHz
16GB Ram
Windows Vista 64 Ultimate
nVidia GTX280

07-06-2009, 03:31 PM
Any official word on this please Ubi, or have we wasted our money?

07-09-2009, 02:47 AM
Hi - as someone has already mentioned this is a problem with either Xeon CPUs or multi cored CPUs. To get around this issue install Winlauncher from http://www.freedownloadscenter...ers/WinLauncher.html (http://www.freedownloadscenter.com/Shell_and_Desktop/Desktop_Toolbars_and_Launchers/WinLauncher.html) and create a new shortcut for Juarez2. Then simply modify the shortcut to only run x1 CPU. Works on my machine. I think that it is pretty poor of the developers not to have tested this!! By the way, the game is quite good and worth the hassle - although a bit too similar to COD5!! ;-)

07-09-2009, 03:38 AM
Hi qwerrty1234,

Thanks for the suggestions.

When I gave it a try I can get the game to run at about 15fps with sound that keeps cutting in and out.

I play a lot of other FPS games (COD, Crysis, Farcry, HL2 etc) on the same workstation and had never had any of these sorts of problems.

I have shelved the game (waste of money) until the developer fixes the problem.

07-10-2009, 02:39 PM
this is probably the most ridiculous problem ever. I mean the RECOMMENDED REQUIREMENTS to play this game states a DUAL CORE!!!And it won't <span class="ev_code_RED">***EDIT***</span> work on a multicore...this is just <span class="ev_code_RED">***EDIT***</span> ridiculous. I've been waiting for this game for a long time, i finally go to the shop and come back home all happy and smile while i'm starting up the game and BAM! assertion <span class="ev_code_RED">***EDIT***</span> error.
I really really really really really hope they are working on a patch.

MY specs btw:
Intel Xeon 2.80Ghz Octo-Core
Nvidia Geforce 9800GT 512MB

oh and plus even setting the affinity to one core doesn't fix the problem.
it starts to lag and then the assertion problem message comes up again...

<span class="ev_code_RED">Please don't attempt to bypass the forum word filterm these forums are E rated for all age groups***</span>

07-10-2009, 03:37 PM
I can verify that doing the msconfig change to 4 cores does work. Like I said before, it is an extreme solution, but it does work. I enjoyed the game, but I'm not likely to be doing much multiplayer until they fix the code for 8-core systems.