View Full Version : Polygon Kaleidoscope w ATI 4850's Crossfired

07-01-2009, 10:51 PM
I have been able to install the game, and everything through the menus and still shots while starting a game appears normal. However, when both single or multiplayer game loads, I just get a kaleidoscope of of flashing multi-color polygons. I have not had problems with any other game I have installed and played on this computer (i.e. Left 4 Dead, Fallout 3, Team Fortress 2). System Profile:
MB: Gigabyte GA-MA790GP-UD4H
CPU: AMD 955 AM3 Socket Quad Core 3.2 GHZ
Memory: 8 GB Corsair Dominator 1066
Graphics: 2 ATI 4850's in Crossfire with latest Catalyst driver package (9.6) set on factory default settings
OS: Vista 64-bit Home Premium
Monitor: 27" widescreen LG 1080P HD Monitor connected via HDMI cable

Things I've tried with no change:
1. De-install, registry clean, and re-install
2. De-install, registry clean, and XP Compatability Mode install from setup file on BIB DVD
3. Ran DirectX update from BIB DVD
4. In-game - Both manually adjusted and default settings and both Monitor and TV options in Gamma. Tried best appearance, balanced, and best performance display settings
5. Disabled Crossfire, restarted, and tried on single ATI 4850
6. Disabled Catalyst A.I. in Catalyst Control Center
7. Downloaded additional copy of game through Steam and have same issue. 1st copy is DVD. I need a 2nd copy anyway for 2nd PC I'm ramping up and just got it sooner than expected to eliminate possibility of bad copy of game.

Please reply with any suggestions. Thank You in advance.

07-01-2009, 11:21 PM
What service pack are you running with vista? You need at least SP1. I also have a ATI 4850 Card and it works fine with the game. If the service pack isn't the issue, I'm not sure what is.

07-01-2009, 11:46 PM
I'm running on Vista SP2 for 64-bit. I made some progress. Got it working by going to Catalyst Control Center and kicking on Triple Buffering in All Settings under 3D. Not out of the woods yet though, had a system lock up shortly into single player game and had to hit reset button.

07-02-2009, 01:12 AM
Been playin multiplayer games and have to say I'm extremely impressed with multiplayer, but am suffering from hard lockups where I have to hit reset button. Based on the way system is responding, I think it's something with vid cards or vid card settings. May try to disable Crossfire now that I've gotten to this point and see if it makes a difference.

07-02-2009, 07:21 AM
I have a 4850 and there is a point in the first chapter where the game locks up my entire computer, and I have to turn it off by the switch. http://forums.ubi.com/images/smilies/disagree.gif

07-03-2009, 12:11 AM
Got the lockups cleared up for the most part with advice from another forum post. Follow the instructions on the following link
http://www.forum.coj-gaming.co...topic.php?f=47&t=134 (http://www.forum.coj-gaming.com/viewtopic.php?f=47&t=134)