PDA

View Full Version : HAWX Saitek X-52 Vista issue



Hajimoto_FOYI
03-02-2009, 08:35 PM
Installed the demo and flew the training flight perfectly. Shut the game down and installed my Saitek X-52 flight control system. Hawx will not play as long as my X-52 is plugged in. Control panel shows all the buttons and axis inputs are reporting fine. Unplug the X-52 and KB Mouse work fine.
Anyone able to assist with this issue?

hoorah2579
03-02-2009, 08:46 PM
I believe in the control options you need to click it over to joystick then apply. Thats how I got my extreme 3d pro to work, but I haven't plugged my x52 in yet.

Darwin11
03-10-2009, 08:11 PM
I can't play the Hawx demo with my X-45 in vista64.

regardless of calibration, the mission select and flight control record a continuous full-right stick input. =(

Foppemoa
03-11-2009, 03:40 AM
I think most issues with the joysticks (not the deadzone issues though) is caused by the joystick software/drivers.

Try to uninstall all drivers and software (guide can be found on the saitek site. quite the hassle since it has to be done manually), and then afterwards just plug the stick into another usb port and only use he drivers windows installs automatically.


my joysticks (x-52 and cyborg X) worked best when i just plugged them in and avoided the drivers like the plague.
When i later on installed the drivers it worked for about 30 minutes and then i got a bluescreen... (google it, seems to be a "feature" of the saitek drivers :P).

StylezZ00
03-11-2009, 04:24 AM
thats odd, my x-52 works just fine (besides the deadzone issue) with all the software/drivers installed and before i installed them

Smokin_Green
03-11-2009, 07:35 AM
At least someone tells us something, thx, ill try this out.

evilducky200
03-11-2009, 09:24 AM
Well thats funny. I have Vista and the X-52 and the software installed and all my flight sim games *FSX, Blackshark and lockon* all work perfectly fine with NO deadzones.. Play hawx, I have that deadzone. But I have never had an issue with the drivers and vista. No BSOD or anything with them.

Crazyglues
03-11-2009, 09:29 AM
Originally posted by StylezZ00:
thats odd, my x-52 works just fine (besides the deadzone issue) with all the software/drivers installed and before i installed them

What do you mean by (besides the deadzone issue) -What is the deadzone issue?

does the joystick have area's that are not reading... like if you move a little to the right instead of hard right?

evilducky200
03-11-2009, 11:11 AM
yeah, like 50% of the joystick is unresponsive when you move it.. Alot of people are having this problem.

QNET_ALIEN
03-19-2009, 02:45 PM
I have the Saitek "Av8r" for PC, and it also has that deadzone issue. I hope this will be patched soon...

MAD-CAT_555
03-19-2009, 03:09 PM
Only minutes ago I succeeded to run the HAWX demo with my X52. I too had the well known problem, that the game wouldn't start when the stick was plugged in. To my surprise, my old Sidewinder Freestyle Pro gamepad worked with HAWX so I tried to plug in both controllers at the same time and it worked! Removing the gamepad produces the well known crash. I don't know if this only works for my PC, if it has something to do with the demo or the Freestyle Pro, but I recommend everybody to try to plug in a second controller. Maybe this works for others too. Good luck!

exovadis
03-19-2009, 03:15 PM
I just try to plug my xbox360 controller in and I did had the ERSB dump crash BUT I removed the saitk x-52 and left the 360 controller and the game booted perfectly the issue is really with the X-52, I have tried with and without driver the issue is the same.