View Full Version : Question about Masyaf free roam

12-10-2011, 09:47 PM
In some trailers (not the realistic one), we see Ezio standing on the platform in Masyaf, where we saw Altair do his first leap of faith. For anybody who has glitched or had the ability in anyway to free roam around Masyaf, have you found a way to reach that platform?

I for one tried of course with Altair in his 3rd memory, but sadly couldn't find a way.
http://www.youtube.com/watch?v=ZtmpPRyBgAs This one shows Ezio standing on the platform near the beginning.
http://www.youtube.com/watch?v...wfHrc&feature=relmfu (http://www.youtube.com/watch?v=6kmulGwfHrc&feature=relmfu) This one shows Altair on the platform and also fighting Crusader knights at night.

If anybody knows a way to get to those platforms, please, don't hesitate to tell me http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif It would be much appreciated.

12-10-2011, 10:26 PM
You remember where you went in AC1 to get to the platforms to perform your first leap of faith right? It's the same path.

12-10-2011, 10:29 PM
The doors aren't open though :/

12-10-2011, 10:32 PM
Okay... I'm not sure at what point your able to get to the plateforms, but I know that you are able to at some point. I've tried and managed to get to the tower where they are...

12-10-2011, 10:33 PM

12-10-2011, 10:35 PM
Same way you do in the very first game. Whe your in Masyaf, and you're at the training ring. There is a ladder there. You can climb up that, and then there is another one.

12-10-2011, 10:36 PM
I'm talking about in Revelations......the ladder that takes you up has closed doors, which restricts you from using the other ladder that takes you even higher.

12-10-2011, 10:38 PM
There should be two ladders there.

12-10-2011, 10:40 PM
Lol there aren't! Have you climbed it in Revelations?

12-10-2011, 10:43 PM
Yeah... I got up there once. I dunno... Next time I go through the game, and figure it out, I'll record it, and upload it to youtube or something.

12-10-2011, 10:44 PM
lol you're lying. I've tried in every sequence possible. And I couldn't find a way up. Those doors the first ladder leads up to is closed bro.

12-10-2011, 10:47 PM
Pause at 5:12 (http://www.youtube.com/watch?v=UGkmua1V-Ek)
Those doors are closed every time you go to Masyaf.

12-11-2011, 09:34 AM
You tried it in the mission 'The Mentor's Keeper'. It's the last mission of Sequence 7. Sadly, there is a time constraint.
You can also try climbing up on the front of the castle anytime you're in Masyaf. This way you don't have to take the first ladder, at least.

12-11-2011, 10:03 AM
Ok I'll give that a try and I'll tell you if it worked http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif thanks bro.

BTW, mentor's keeper is memory 8 in sequence 3.

12-11-2011, 10:41 AM
Here's what I got. I found a way to get around that place where you find Abbas with the apple, and I took like 5 risky jumps and I finally landed in that place from AC1. You know where you do the leap of faith then you come up to that wall, that's where I am. But there are no logs to take me to the other side.