PDA

View Full Version : Prince of Persia doesn't start



DeathRay2K
03-25-2009, 06:50 PM
I just bought Prince of Persia on Steam, and I can't get it to run.
From Steam it opens the launcher, but when I hit "Launch the Game!" it just closes the launcher and the game doesn't load.
I'm using Vista Ultimate 64-bit.

caswallawn_2k7
03-25-2009, 06:57 PM
if you need help you need to post a dxdiag. as with you only saying what your OS is there could be litteraly millions of things causing the problem.

kakalukiaJay
03-25-2009, 07:10 PM
What is "steam"?

Are you talking about the latest "next gen" Prince of Persia or which other POP game?

The earlier POP games were written before Vista and for one cpu computers.
There are published work-arounds for Vista "run as administrator" and how to get the programs to run on just one of your cpu chips.

DeathRay2K
03-25-2009, 07:18 PM
DXDiag (http://www.d2kstudios.com/imwalkingonsunshine/DxDiag.txt)

Steam is a digital distribution service.
I am indeed talking about the latest PoP.

caswallawn_2k7
03-25-2009, 07:24 PM
remove the overclock from your CPU and if you havve one on your graphics card remove that. this game is built on the same engin as Assassins creed and neither game like overclocked hardware as it pushes the hardware to the limit's causing loads of errors as overclocked hardware is never 100% stable and the higher you go the worse it gets.

DeathRay2K
03-25-2009, 07:44 PM
Using stock clock speeds didn't help.
And it wouldn't, the PoP process isn't even being launched, there's no reason a CPU overclock would affect that. Besides, my overclock was rock solid. Overclocking doesn't make things unstable, and is often the only difference between the stock parts!

DeathRay2K
03-27-2009, 07:08 PM
So can anyone help with this? Ubisoft support seems to be pretty much clueless, they responded telling me that Vista isn't supported, and next time to look on the bottom of the box at the system requirements, even though I'd submitted the question as "purchased on Steam". Plus, there's the fact that Vista is listed in the requirements...

joey_junior
03-28-2009, 05:12 AM
my quess is that you just need to buy the game on PC-dvd, and install it from there.
ive experienced the same problem with other games i downloaded, they just wont start. then i bought the disk, and suddenly it started!

curlyhairedboy
03-28-2009, 04:28 PM
i'd suggest redownloading, as inconvenient as that sounds. but i've got the game running on Vista Ultimate 64, in 64 bit mode, with my graphics card overclocked, and it's going great. i know it can run on vista. try the redownload, and see if that fixes things.

DeathRay2K
03-28-2009, 04:34 PM
I already tried redownloading, and verifying the game cache, but to no effect.

curlyhairedboy
03-28-2009, 11:43 PM
try adding -32bit to the launch options in the game properties.

DeathRay2K
03-29-2009, 10:07 AM
Again, already tried without effect.

moleiche3
04-09-2009, 07:00 PM
i have the same problem exept it is on windows xp 2000
the game will just not start http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

lp3hora
06-20-2009, 04:23 PM
Guys, I discovered how to solve this problem:

You must do the following: Make CTRL + C and CTRL + V in the file " "PrinceOfPersia_Launcher.exe" and rename the new file to "Prince Of Persia.exe".

Thus, in the game folder there should be two files ".exe": one with the name "PrinceOfPersia_Launcher.exe" and another named "Prince Of Persia.exe".

I hope have helped you. http://forums.ubi.com/images/smilies/59.gif

jerdna2009
07-24-2009, 03:16 AM
????? ?????? "????? ???????" ?? ???????????, ??????????? "vista". ?????? ????????????? ? XP, ??? ???????????

kakalukiaJay
07-24-2009, 08:33 AM
jerdna2009, forum rules require all discussions to be conducted in English.
Please use a translation website if necessary.
Thank you.

jerdna2009
07-25-2009, 12:19 AM
[QUOTE] ????????????? ??????? jerdna2009:
????? ?????? "????? ???????" ?? ???????????, ??????????? "Vista". ?????? ????????????? ? XP, ??? ??????????? [/ QUOTE]

jerdna2009
07-25-2009, 12:28 AM
The Prince of Persia "sands of time" are not started. Operatsionka "Vista" i place on the compatability with "XP". Without it is resultant

kakalukiaJay
07-26-2009, 09:29 AM
Are you installing on Vista ... or in a "virtual machine"/"virtual partition" running Windows XP?

What is your error message or what is your problem?

raminarya
08-05-2009, 10:09 AM
Did anybody find a solution to this problem? I have exact seem situation: PoP-2008 on Vista64 purchased on Steam, doesn't run after the initial window (I click on Launch and window closes and nothing else happens)
I tried compatibility mode, run as admin, and that two-exe-file method posted earlier.

raminarya
08-07-2009, 03:26 PM
I fixed the problem by re-installing. Finally it installed correct dx and vc redist

Nansaila
05-21-2010, 04:03 AM
jerdna2009 (she/he writes in Russian) tries to install Sands of Time on Windows Vista, but the game doesn't launch. She\he sets compatibility with WinXP, but it doesn't help: nothing changes.
I think jerdna2009 has the same problem as I do: StarForce is complaining, that its drivers don't suit.
I read through some topics related to the problems with PoP on Vista, but I can't understand: StarForce and Ubisoft do nothing and we must give up hope to launch and play games? Aren't there anything possible to do?!
Thank you for your attention =)