PDA

View Full Version : Help me get the game to run smooth....



rangerjoe84
05-04-2006, 11:32 PM
Hey guys. I am new to the forum. I really like this game but can't seem to get rid of small in-game freezes and stutters. Most of these occur when there is AI radio chatter. I think that its a sound problem. My PC has 512mb ram and on board sound. Which would do more to help me play the game smoother-a new audigy 2 sound card or an extra 512mb stick of ram? Have other people had this issue? Are there other fixes? Thanks guys.

Freelancer-1
05-05-2006, 12:09 AM
Hi rangerjoe,

Nice to see a new player joining the forums http://forums.ubi.com/images/smilies/25.gif

There are answers in here, but I'm not one of the people with them. If you repost in the "Community Help" forum, however, I'm sure you will have your problem fixed in no time. Very helpful bunch of folks over there.

Cheers,

Xiolablu3
05-05-2006, 12:48 AM
More RAM m8, although a hardware sound car would do better to, but dont spend much on one, its not worth it.

My Advice, get both.

Buy a Soundblaster Live! off ebay for around $4/3. (This is a hardware sound ccard taking the load off your CPU, and you will hardly see any difference from a expensive Audigy.)

AND buy 512 mb ram, off ebay you vcan get 512 of good ram for around 30, not sure about dollars for this. Be sure not to get the very very cheap hi density stuff tho.

Where do you live? You should be able to get both for under 40 plus P&P if you are in the UK.

IL2 needs at least 1gb ram to run smoothly at any kind of decent looking settings. What Graphics card do you have?

Hashmark13
05-05-2006, 12:55 AM
www.newegg.com (http://www.newegg.com) for hardware.

Ebay = no returns.

newegg is only for U.S. people.

If you had posted your hardware specifications, we could have instantly told you what to upgrade and what is fine.

WTE_Galway
05-05-2006, 01:10 AM
Originally posted by rangerjoe84:
Hey guys. I am new to the forum. I really like this game but can't seem to get rid of small in-game freezes and stutters. Most of these occur when there is AI radio chatter. I think that its a sound problem. My PC has 512mb ram and on board sound. Which would do more to help me play the game smoother-a new audigy 2 sound card or an extra 512mb stick of ram? Have other people had this issue? Are there other fixes? Thanks guys.

You have not mentioned the system type or graphics card model or what settings you run ingame for video and sound.

I am running 750 RAM and still get a few stutters and long load times so 512 is definitely not enough for smooth play.

The sound thing is suspicious though .. have you tried winding back the sound settings or disabling sound to see what happens ? If you do replace the sound card get something lke an audigy that does sound processing onbard and takes some of the load off the processor.

Xiolablu3
05-05-2006, 02:09 AM
i have bought around 40 computer parts off ebay and not one has been faulty.

Even if one was then I have still saved enough to pay for it 3 times over on the other things I have bought.

Just a few recent items :-

MS Sidewinder Force Feedback Pro 2.99
Soundblaster Live! for the gameport only - 2
The Big Show - Pierree Clostermann - .99p
Nice Computer CAse plus 400watt PSU - 19.99 new
New COrsair 512mb Ram Cl 2.5 - 25.99



Also built a whole computer from parts off ebay.

General rules - Never spend over 50 ever unless its from an established Ebay Store,
Always CHeck feedback and the items sold before. Never buy anything which says 'could be faulty' or 'dont know if it works'

Read the description thouroughly.

rangerjoe84
05-05-2006, 12:47 PM
I am running excellent settings all around 1024x768 with 2xAA and about 30-40 fps. I really would rather run perfect landscape settings and low everything else because that water is awesome. With the "perfect" settings I get bad stutters but a fairly solid frame rate at about 30-35. I have disabled sound which helps a bit. But whats weird is that it still stutters when the ai radio subtitles come on screen even with sound off. If I turn subtitles off and sound back on, it stutters when the voices come on. I can tell at times that I am low on ram because i see my hard drive light come on. This is actually on a laptop with the ati x300 video card. Sorry for the long post. Thanks.

Taylortony
05-05-2006, 01:38 PM
this was how one person sorted it

http://www.sim123.co.uk/il2help.htm

carguy_
05-05-2006, 02:07 PM
I`d like to try that Directx.cpl applet but link is dead.Anyone?

GreyBeast
05-05-2006, 04:04 PM
Originally posted by rangerjoe84:
Which would do more to help me play the game smoother-a new audigy 2 sound card or an extra 512mb stick of ram?

Get both

Xiolablu3
05-05-2006, 05:49 PM
Originally posted by carguy_:
I`d like to try that Directx.cpl applet but link is dead.Anyone?

Is this what you mean, Carguy?

http://www.softpedia.com/get/System/OS-Enhancements/Mic...-Control-Panel.shtml (http://www.softpedia.com/get/System/OS-Enhancements/Microsoft-DirectX-Control-Panel.shtml)

Xiolablu3
05-06-2006, 05:47 PM
Hmm not even a thankyou, it really warms the heart http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

JFC_Rautaristi
05-07-2006, 01:06 AM
I'm running only 512mb ram and it really isn't enough. I've been thinking of upgrading to 1gb and now i just might have the money.

The average fps is rarely an issue for me, as long as it stays over 10fps in heavy areas it's fine and usually is over 20. I run the game in perfect mode with water=0.

Another weird thing is that i don't have any difference at all in performance between excellent and perfect when water is set to 0.