PDA

View Full Version : "Perfect" works perfect! Only...



XyZspineZyX
09-14-2003, 09:41 AM
Running Perfect now on Radeon 9700, Cat 3.7 drivers, and it works better than on any previous drivers. With 3.4 I'd get psychedelic artifacts in the distance, and with 3.6 it would simply lock up. With 3.7 it now works perfect.

Only...

Well, I get these weird artifact lines on river banks. It may not seem important, but the whole point of "perfect" is to be, well, perfect. /i/smilies/16x16_smiley-happy.gif These ugly lines in the textures are a definite nuisance, and I was wondering if anybody else had a fix for it? I remember vaguely somebody talked about disabling stencil buffer, but that now seems impossible to do!

Any hints?


--
Joques
Ok, so you've got a Yak
That don't impress me much

XyZspineZyX
09-14-2003, 09:41 AM
Running Perfect now on Radeon 9700, Cat 3.7 drivers, and it works better than on any previous drivers. With 3.4 I'd get psychedelic artifacts in the distance, and with 3.6 it would simply lock up. With 3.7 it now works perfect.

Only...

Well, I get these weird artifact lines on river banks. It may not seem important, but the whole point of "perfect" is to be, well, perfect. /i/smilies/16x16_smiley-happy.gif These ugly lines in the textures are a definite nuisance, and I was wondering if anybody else had a fix for it? I remember vaguely somebody talked about disabling stencil buffer, but that now seems impossible to do!

Any hints?


--
Joques
Ok, so you've got a Yak
That don't impress me much

XyZspineZyX
09-14-2003, 08:52 PM
Shameless bump...

--
Joques
Ok, so you've got a Yak
That don't impress me much

XyZspineZyX
09-14-2003, 08:55 PM
Errr, I couldn't tell you how to get rid of those lines since running 'perfect' is rather out of the question for me.
I do recall reading however(in a patch readme I think) that stencil buffer 'on' and 'perfect' settings go together.

<center>http://users.compulink.gr/ilusin@e-free.gr/bf109[2)1.jpg

XyZspineZyX
09-14-2003, 10:09 PM
You mean lines like these? You wont notice them while everything is moving but for screenshots you can...

http://shredz2001.homestead.com/files/SS/il2_.jpg



Message Edited on 09/14/0301:12PM by ShredZ

XyZspineZyX
09-14-2003, 10:42 PM
Slightly off topic, (sorry if I'm hijacking the thread!) are there any other enhancements in Perfect mode (over "Excellent") apart from the water pixel-shaders?

My system can run it ok but I prefer to keep the framerate high and forgo the water fx - which I don't actually like from high altitude. Admittedly they look pretty special when you're flying low. I couldn't see much else different, am I missing something?

XyZspineZyX
09-14-2003, 10:53 PM
ShredZ wrote:
- You mean lines like these? You wont notice them
- while everything is moving but for screenshots you
- can...

Yes, that's exactly it! I can't take screenshots myself (having an ATI card) but that's it.

I do notice them while moving, but then I am pretty picky. /i/smilies/16x16_smiley-happy.gif Is there anybody who doesn't get those lines? I notice that in Shredz' screenie they are more pronounced on the far riverbank than the close one.



--
Joques
Ok, so you've got a Yak
That don't impress me much

XyZspineZyX
09-14-2003, 10:59 PM
You can take screenshots with 3.7 catalist driver.

XyZspineZyX
09-14-2003, 11:22 PM
^^^ Yup, I couldnt take SS for such a long time, upgraded just a week ago and Im back in business!

-catalyst 3.7-

XyZspineZyX
09-15-2003, 07:04 AM
Aha, that is cool!

But...it doesn't really solve the problem with the lines. Anybody else know? Is it ATI-specific, for instance?

--
Joques
Ok, so you've got a Yak
That don't impress me much

XyZspineZyX
09-15-2003, 09:08 AM
joques wrote:
Yes, that's exactly it! I can't take screenshots
- myself (having an ATI card) but that's it.

if you are running 3.7 cats your screenies should work again .
A