View Full Version : PF planes and missions haven't worked since 4.01m, Don't work with 4.02m

10-19-2005, 10:43 AM
Posted Mon October 17 2005 19:16
Originally posted by Pteranodon:
First of all, i wanted to say "Thanks for the patch, Oleg and company".
I know already,that i and alot of other people will enjoy it.

But i encounter a little bug,i think.
I cant fly a P40, version B and C.
When i want to fly the plane,i cant get into cockpit view,only external and flyby.
In the external view,the plane is also not responding on the x45.
The other planes no problems so far.

I am seeing this problem. Here's my description:

I validate that all works after each patch then I load 4.01m (on a merged install at the very end) and some of the PF fighters (missions and quickbuilds or full blown custom missions that include a specific set of PF planes don't work [P-40, wildcat, curtis varients, etc])
I uninstalled and reinstalled the products. Same Result right after 4.01m is installed.

I took a video of what happens and with manual cameras enabled. The mission starts like when playing the game, in the (broken)default view, but when you move the camera around a little everything seems to be okay, but joystick input isn't working. Its almost as if the pilot location for these aircraft is horked up...and that the game is playing fine.
Is anyone interested in the file?

Also, I've noticed another curiousity, in the USMC fighter campaign I only have the option for a P-39. I love the P-39 but it was NEVER a Marine Corps ride as far as I know. I think it has to do with all the USMC and USN Planes being jacked...

And finally when I install PF stand alone with all the patches everything works great.

Thanks for your help.
and let me know an anwer or where I can post this video file.


10-19-2005, 11:54 AM
Some of this was an issue with PF standalone and Merged installs when PF came out

As you have seen, it was fixed in a patch

It was fixed in both Merged and Standalone versions, be sure.

I made a campaign using the H81A-2 (P-40B), and a few players couldn't play- they had no coclpit, couldn't do anything at all

In each case, as far as I know, it was traced to a bad patch or patching sequence error

The P-40 cockpits not appearing is not normal; there are cockpits for those planes and always have been

Somewhere along the line, a patch was corrupted when you downloaded, or the wrong sequence of patches was applied, or something else went wrong, because 100% absolutely those pits are present

Double and triple check your isntall and patch sequence. You shouldn't have these troubles, merged or standalone

10-19-2005, 03:05 PM
Patch order.

PF3.03m (100mb patch version)

ANY deviation from that patch order will totally bugger things up. Do not install 3.01m, 3.02m, 3.04m or anything else.

Also beware of some rogue 4.02m's that were swapped with 4.02's. Make sure your 4.02m is 30mb(ish) and not 25mb.

10-21-2005, 07:12 AM
Right, thanks guys. I will download new patch files and see what happens.


10-23-2005, 07:38 AM
I'll have to say I didn't think this would work, but I deleted all of the patches I had and downloaded from a new source. Merged Game now works GREAT!

BTW...in mission building I discovered the same symtoms when I tried to run a built mission without selecting a player or point of view.

Apparently something in the first round of downloads was corrupt.

Thanks for the help.