PDA

View Full Version : The same game, the same operating system yet...



ryandwigginton
09-29-2009, 11:36 AM
A school friend I used to link up with years ago on the old Commodore Amiga, wanted to re-unite in the skies. Having owned Forgotten Battles, I knew it was perfect for us yet I also knew it would not play on Vista 64. So I convinced him to come out with me and buy 1946 (I'd read this does work). We both bought the game and went home excited. So far... simple.

My disc installed using setup.exe and run as administrator. No problems, and played first time. My friend however was (and still is) having issues. Setup wouldn't run for him, and he had to install using a.exe. Once it installed though and he tried to run the game, in directx mode it says d3d8.dll is missing, and in opengl mode the desktop shortcut appears to do nothing.

I tried all the obvious such as removing his anti-virus completely, compatibility mode (XP SP2) and updating his video drivers.

What baffles me is, he is running the same operating system ie. Vista 64, and the same version of the game, yet we both get completely different results. It's frustrating. I can't blame Ubi or Maddox since it doesn't mention supporting Vista on the box but is their anything else we need to try? Can my friend download this d3d8.dll and if so, where does it belong?

Any help will be greatly appreciated.

K_Freddie
09-29-2009, 01:59 PM
Not sure with vista, but in all previous windows OS's, DDL files should either be in the C:\WINDOWS\system32 or the application (IL2) folders.

I think vista might have an upgraded version of DirectX, and has given it another name.

Do a search for "*.dll", and you'll find a sh1tload of DLLs in one of the system folders - this is th eplace to put the dll, if it exists.
http://forums.ubi.com/groupee_common/emoticons/icon_cool.gif

JtD
09-29-2009, 02:09 PM
You can copy your installation onto your friends computer or a flash disc or external HD and start it from there by going into the 1946 folder and double clicking on the il2fb.exe.

This way you can check if it is a problem with the 1946 installation or with your friends computer. I have a laptop with Vista and it runs without problem.

M_Gunz
09-29-2009, 03:56 PM
Good luck Ryan! I used to have an Amiga 1000 and ran Bob Dinnerman's F/A-18 on it, great sim for back then, 1988 IIRC.

Urufu_Shinjiro
09-29-2009, 04:00 PM
He needs to run the il2setup.exe and select his settings there, if the hardware settings are not correct then this can happen sometimes. Also if he clicks on the icon and then his pointer turns into a spinning disc and then nothing post back here and I'll send you a private message with the fix (since the fix cannot be discussed in the open http://forums.ubi.com/images/smilies/53.gif).

ryandwigginton
09-30-2009, 02:52 AM
Originally posted by M_Gunz:
Good luck Ryan! I used to have an Amiga 1000 and ran Bob Dinnerman's F/A-18 on it, great sim for back then, 1988 IIRC.

Amazing game. It had great atmospherics, and felt kinda spooky and ominous with that deep flat electronic tone on the menu screen! I was age 10 lol. A couple of early ones I relished were Spectrum Holobytes Flight of the Intruder and also Microprose B17 Flying Fortress. The one my friend and I used to link on often was Knights of the Sky. There were a lot of WWI sims back then...

Thanks for the responses!

ryandwigginton
10-01-2009, 02:47 PM
Thanks so far. Drove over earlier and got my friends IL2 running using a copy of my game folder. Must have been a bad install from his disc.

We were expecting a dogfight tonight but hit brickwall again.

First we tried connecting using the game interface. I know, everyone uses Hyperlobby but for one on one shouldn't the create server server/join server in game work? We had no joy with it whatsoever. Used ipconfig to get my ip address, sent it to my friend, he put it in both by itself and with :21000 after and neither worked.

We then attempted hyperlobby, but it kept on asking for my friends game path. He copied it from the desktop shortcut properties (for my install). He said he saw a list of names once and saw me in there but then suddenly it said it couldn't find the game path again. We selected Forgotten Battles by the way, and not IL2.

We gave up for tonight... why is it this difficult? I consider myself experienced with games and computers, my friend not so much, but it makes me think, if we were two average joes off the street we would have no chance.

Anyway, simple help for starting a multiplayer would be appreciated.