PDA

View Full Version : [Anno 1503] Campaign bug. and two little bugs



PumaRalant
06-30-2020, 07:03 AM
Hello,

Have played the game for a few hours so and I have been mostly been enjoying it. There are unfortunately a few bugs in the game. Some are just details, and one is game breaking.

-> The soil fertility icons are wrong in the tobacco island, because you have the spice icons in there.
-> Those vertical reddish stock level of your merchandise in the marketplace aren't indicating properly your supplies levels. Some with 20 tons will have the same levels as ones with 230 tons.

But the game breaking bug and most urgent one is right after you finish the nova fora mission right where you have the "cinematic" telling you to build Covana. This picture down there is what I have.

https://imgur.com/a/jXiVAsu

I don't know if it's affecting only me.

My system is:
PC windows 10
intel i7-8700k
RTX 2070
16 Gb of Ram
Monitor 3440x1440

The ships that I send to the east of Nova Fora to trigger the covana mission are with two little warships filled with the supplies and army.

insaniacx
06-30-2020, 06:08 PM
I had the same issue but when I press ALT-TAB and switched back to the game it was OK.

PumaRalant
06-30-2020, 09:47 PM
I tried but it didn't work. Was there something else you did?

https://www.youtube.com/watch?v=quPAO1knhQQ&feature=youtu.be

poppi9924
07-01-2020, 01:53 PM
Exactly the same issue for me, I tried it multiple times, each time after ending the first campain part I was greeted with that screen. Tried different ships, with cheats and without, nothing helped. Alttabbing also didn't fix it for me. Also, when you restart the game you don't have access to the second mission.

My specs:
Win 10
GTX 1070
i7-6700k
16GB RAM
Resolution 3840 x 2160

PumaRalant
07-01-2020, 07:15 PM
I have found a roundabout way to solve this issue.

Finish the nova fora mission by sending the two ships.
You'll get the cinematic leading you to the covana mission.
Once you get that weird buggy screen, press F10 to save your game. Then Alt F4 to close your game.
Relaunch the game. Then go to your save and select "Lastgame". The game will be playable again.
BUT...the covana mission wont appear in the campaign list.

https://youtu.be/NC0W_A3Uceo

PumaRalant
07-01-2020, 08:03 PM
Exactly the same issue for me, I tried it multiple times, each time after ending the first campain part I was greeted with that screen. Tried different ships, with cheats and without, nothing helped. Alttabbing also didn't fix it for me. Also, when you restart the game you don't have access to the second mission.

My specs:
Win 10
GTX 1070
i7-6700k
16GB RAM
Resolution 3840 x 2160

Cheats? How? Where did you find those?

Ubi-Litten
07-02-2020, 08:42 AM
Hi all, thanks for getting in contact and providing this feedback / workarounds, I will certainly be sure to forward this feedback to our development team for further review.

In the meantime, if you are still experiencing this or would like to provide any additional feedback, please feel free to let us know.

poppi9924
07-11-2020, 08:50 AM
Another update from my side, same issue happened when the second campaign mission ended and I got transitioned to the third one

Ubi-Raziel
07-14-2020, 04:20 PM
Another update from my side, same issue happened when the second campaign mission ended and I got transitioned to the third one

Hey, thank you for keeping us up to date.

It is unusual why this only seems to be affect a small amount of players. Considering alt-tab worked insaniacx above, I wonder if there is some conflicting software.

Perhaps try disabling background applications to see if that helps: https://support.ubisoft.com/en-GB/faqs/000025721/

Please also make sure you have verified your game files: https://support.ubi.com/en-GB/faqs/000025650/