PDA

View Full Version : [Crash/Freeze] Game will not launch



tadman135
05-16-2020, 11:57 PM
Hi everyone,

Windows 10 Machine, game downloaded.
When I try to start it (either from UPlay or from application file in game directory) nothing happens. I get splash-screen png but nothing afterwards.
Anyone else encounter this? Suggestions to solve?

Many thanks! :)

galadriel_7
05-17-2020, 08:51 PM
The stand alone launcher for Discovery tour ancient Greece hangs indefinitely...
Does anybody have a solution?

millejos13
05-18-2020, 04:22 AM
I am also having this problem with the ancient Egypt one (Greece is still downloading) Windows 10 64-bit and unable to launch.

khal9999
05-18-2020, 08:00 PM
I had the same issue today, and also the Egypt tour crashed at various points during the first tour. I tried verifying the files, which came up with errors - after letting the repairs finish all is OK. (I'd downloaded both of the tours yesterday, without interruption, so was a bit surprised there were errors!)

Ubi-Woofer
06-12-2020, 09:14 AM
Hey all,

If experiencing issues with either of the Discovery Tours, I'd recommend following this guide (https://support.ubi.com/en-GB/faqs/000025947/Basic-PC-Troubleshooting/) first to troubleshoot these. If issues persist, please let us know.

Verifying the game files (https://support.ubi.com/en-GB/faqs/000025650/Verify-Game-In-Uplay) - as khal9999 mentioned above - is one of the first steps, and will repair any missing or corrupted data. :)

nxk00
10-05-2020, 11:07 AM
I have uninstalled / reinstalled the game and Uplay both twice. I have verified the files. I have emptied the cache file.
Still won't launch. Crashes after "press any key."

Ubi-Redbeard
10-08-2020, 07:35 PM
Hey nxk00,

Do you receive an error message at all when the game crashes?

danijel.1983
10-09-2020, 04:51 PM
I'm experiencing the same issue with Discovery Tour Ancient Greece on Windows 10 64-bit. I get the splashscreen png which disappears after a moment and the game never launches. All game files have been successfully validated. :confused:

Ubi-TheBerry
10-10-2020, 01:29 PM
I'm experiencing the same issue with Discovery Tour Ancient Greece on Windows 10 64-bit. I get the splashscreen png which disappears after a moment and the game never launches. All game files have been successfully validated. :confused:

Hey there!

Sorry to hear you're having issues.

Have you tried any of the further troubleshooting steps from our guide (https://support.ubisoft.com/en-GB/faqs/000025947/Basic-PC-Troubleshooting/)?