PDA

View Full Version : A petition to UBI......



Bearcat99
05-09-2006, 06:48 PM
The release of the Pe-2 add on was frought with all kinds of problems, many like the difficulty in paying for the thing in the first place, that NEVER EVER should have happened. Now I can understand why we may never see a CD here in the US or anywhere outside of Russia... and I can dig it.... even if I dont like it I understand it. However.. Ubisoft... can you PLESAE PLEASE PLEASE make the next add on easier to buy. Can you add a PayPal option to your site. Many people use PayPal.... you dont want piracy and yet you make the product full of twists and turns to buy. PayPal is easy... and it is secure. Please use it. Many people couldnt get thier Visa cards to work. Myself included. PayPal would go a long way to making that a moot point. Some people dont have credit cards.... but PayPal is not hard to set up. Also..... how hard would it be to post an option to pay for the add ons in U.S. dollars.. how much bandwidth would that take? Not much I am sure. From where may in the U.S. sit you are biting your thumb at us..... not very good business practice. Just food for thought to consider.

PBNA-Boosher
05-09-2006, 06:50 PM
http://forums.ubi.com/images/smilies/agreepost.gif

SeaFireLIV
05-09-2006, 06:52 PM
Gotta agree. I can understand why they don`t distribute it in stores (probably not worth the overhead).

Recon_609IAP
05-09-2006, 06:56 PM
S! Thanks Bearcat, I agree.

Please make it easier - we have people that don't mind buy it online but had issues and that is a shame.

It's good to make it easy to purchase and download/setup.

Thanks for listening..hopefully http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Kid_kreole
05-09-2006, 07:31 PM
Bearcat, well said! I couldn't agree more.

_VR_ScorpionWorm
05-09-2006, 07:35 PM
PayPal, I agree, feel more secure using this option than a straight transaction. Been using it on Ebay and have yet to have a problem with using PayPal.

hotspace
05-09-2006, 07:36 PM
http://forums.ubi.com/images/smilies/agreepost.gif

Rjel
05-09-2006, 07:41 PM
Mark me down as in favor of Bearcat's petition. Why Ubi would ignore the U.S. market is beyond me. They're leaving the door open for someone to sneak into an already small customer base.

WTE_Galway
05-09-2006, 07:48 PM
I agree.

Regardless of the "secret not to be discussed" reasons Maddox products appear to no longer be sold directly in the US .. putting a US dollar option on the UK site seems just sensible.

Crash_Moses
05-09-2006, 08:08 PM
Yup!

HerrGraf
05-09-2006, 09:33 PM
You get my support in this Bearcat. This is the first request aimed at the correct authorities. I hope that they are listening.

HelSqnProtos
05-09-2006, 09:38 PM
S~!

You should add a poll to this thread Bearcat. Ubi likes polls.

Stigler_9_JG52
05-09-2006, 10:01 PM
http://forums.ubi.com/images/smilies/agreepost.gif

Probably makes too much common sense for them to understand, though.

Targ
05-09-2006, 10:07 PM
Paypal would be nice for people to pay for sure.
I dont see the need to post the sale in dollars though as the cost is 9.99 pounds.
There are currency converters all over the net and heck, they even publish it in the money section of newspapers every day the exchange rate for most currency's.

Jatro13th
05-09-2006, 10:07 PM
BUMP!!!

GAU-8
05-09-2006, 11:58 PM
bump....

Feathered_IV
05-10-2006, 12:03 AM
burp http://forums.ubi.com/images/smilies/25.gif

VV_Holdenb
05-10-2006, 01:24 AM
http://forums.ubi.com/images/smilies/agreepost.gif http://forums.ubi.com/images/smilies/clap.gif
I agree - wot Bearcat and SeaFire said.

Xiolablu3
05-10-2006, 01:53 AM
Totally Agree.

I want to buy the addon, and I am not sure which is the best/simplest way to do it.

Akronnick
05-10-2006, 03:36 AM
http://forums.ubi.com/images/smilies/agreepost.gif

slipBall
05-10-2006, 03:47 AM
I did'nt get pe2 because of the whole situation. PayPal is a good idea for future releases

RegRag1977
05-10-2006, 05:22 AM
Yes, i'm with you Bearcat!

Shrike_UK
05-10-2006, 05:34 AM
Ooh what a nice moderator! http://forums.ubi.com/images/smilies/clap.gif http://forums.ubi.com/images/smilies/metal.gif

well said Bearcat http://forums.ubi.com/images/smilies/agreepost.gif

lowfighter
05-10-2006, 05:46 AM
http://forums.ubi.com/images/smilies/25.gif

Worf101
05-10-2006, 07:05 AM
Gotta back my Squadron Leader on this one. PayPal keeps me in my ebay addiction. PayPal is slicker than snot from a 5 year old's nose. It would have made this whole purchase thang, a breeze. It was easier for me because I have Amex, but not everybody has a choice of cards.

Da Worfster

erco415
05-10-2006, 11:23 AM
http://forums.ubi.com/images/smilies/25.gif Count me in. Hey Ubi, how often do you get people asking you to make it easier to give you their money?

horseback
05-10-2006, 11:31 AM
What erco said. I'm in.

cheers

horseback

Swivet
05-10-2006, 01:03 PM
Plus if you never fly the plane to begin with, why must one have it just to play in HL, i mean just make that plane unavailable to those who dont have it.
There isn't many 4.04m servers now that PE-2 came along..
I dunno just my 2 cents http://forums.ubi.com/images/smilies/shady.gif

Old_Canuck
05-10-2006, 01:14 PM
http://forums.ubi.com/images/smilies/agreepost.gif

VF-51-Dart
05-10-2006, 02:27 PM
Agreed! http://forums.ubi.com/images/smilies/25.gif

Bearcat99
05-10-2006, 03:05 PM
Originally posted by Swivet:
Plus if you never fly the plane to begin with, why must one have it just to play in HL, i mean just make that plane unavailable to those who dont have it.
There isn't many 4.04m servers now that PE-2 came along..
I dunno just my 2 cents http://forums.ubi.com/images/smilies/shady.gif

I'm not sure what you are suggesting but The reason why it is this way is because once a new object is added to a version it becomes different and the two will not work together. Keep ihn mind that the code for this sim is if I am not mistaken just a modified IL2 code.. and thatcode is what.... 6 years old... if you include developement time if not a bit older? That is why previous versions are uncompatible.. I am not sure if it is a finely tuned globsal FM or what....

Swivet
05-10-2006, 03:47 PM
Originally posted by Bearcat-
" I'm not sure what you are suggesting but The reason why it is this way is because once a new object is added to a version it becomes different and the two will not work together."


What i mean is that people should still be able to fly in a server or a game even if the mission is not using the PE-2 or if it is, then the plane isn't availabe. Give the player another choice of planes. But oh well
Hey it's cool tho. If ppl want it, then fine otherwise they can stay in the 4.04m servers which there aren't as many.....
Ok i babbled enough....... http://forums.ubi.com/images/smilies/35.gif http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif

fordfan25
05-10-2006, 07:05 PM
Originally posted by Swivet:
Originally posted by Bearcat-
" I'm not sure what you are suggesting but The reason why it is this way is because once a new object is added to a version it becomes different and the two will not work together."


What i mean is that people should still be able to fly in a server or a game even if the mission is not using the PE-2 or if it is, then the plane isn't availabe. Give the player another choice of planes. But oh well
Hey it's cool tho. If ppl want it, then fine otherwise they can stay in the 4.04m servers which there aren't as many.....
Ok i babbled enough....... http://forums.ubi.com/images/smilies/35.gif http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif yea i agree.

Targ
05-10-2006, 07:16 PM
Well, if you want a 4.04 server to fly on than go to it!
No one is stopping you as all of the servers are run and paid for by the community at large, go ahead and toss your hat in the ring and put your money where your mouth is.

Swivet
05-10-2006, 10:10 PM
There's always one!.... http://forums.ubi.com/images/smilies/shady.gif http://forums.ubi.com/images/smilies/59.gif

Bearcat99
05-10-2006, 10:56 PM
Originally posted by Swivet:
Originally posted by Bearcat-
" I'm not sure what you are suggesting but The reason why it is this way is because once a new object is added to a version it becomes different and the two will not work together."


What i mean is that people should still be able to fly in a server or a game even if the mission is not using the PE-2 or if it is, then the plane isn't availabe. Give the player another choice of planes. But oh well
Hey it's cool tho. If ppl want it, then fine otherwise they can stay in the 4.04m servers which there aren't as many.....
Ok i babbled enough....... http://forums.ubi.com/images/smilies/35.gif http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif

They can do that already.... but whether you fly the Pe-2 or not.. or even if it available in the mission.. the vertsions have to be compatible anyway. I think I get what you are saying... but I dont see how that would work.

-HH-Quazi
05-10-2006, 11:28 PM
Targ has the best suggestion. A few of these 4.04M m8s should get together, pool their $$$ together, and crank up a 4.04M server. If I had an extra rig laying around here, I would crank one up for them, as long as the Comcast bandwidth police wouldn't stop by and ask what I am doing with all the bandwidth I am using up. HEHE But I would if I had the rig to do it with. And it doesn't take all that much of a rig to make a decent server. That is a good thought Targ m8. Some of you 4.04M m8s should consider it anyway. If I were in the same boat, I believe I would take it upon myself to put a decent rig together and cranking a server up with full map rotations. It would be a stretch handling 16 m8s at once on my bandwidth of 768Kb up and 8Mb down, but at least it would be available to our 4.04M members.