PDA

View Full Version : mouse inverted?



Banez86
01-15-2020, 11:32 AM
Hi.

I've played settlers 1 and 2 and i noticed that when you move mouse left, it goes right and other way around. This doesn't happen to me in any other games and i recall from past games that settlers had mouse control normal.

Is this a feature or a bug?

Ubi-Orion
01-20-2020, 07:16 PM
Hey there, Banez86.

No this isn't a feature and this issue doesn't appear to have been reported to us. Can I ask you to to ensure that any controllers you have are currently disconnected and then to try running the game following a clean boot (https://support.microsoft.com/en-us/help/929135/how-to-perform-a-clean-boot-in-windows) please? These steps should ensure that the issue isn't being cause by external hardware or software

Thanks!

Banez86
02-12-2020, 09:44 PM
Hey there.

Apologies for getting back about this so late.

After reading my original enquiry i realized i didn't explain the whole issue as best as i could.

So here is proper explanation of the issue:

Normally the mouse works fine, i dont have controllers or anything, I've always used right click move when i move the map or the area i'm building on and currently it happens when i press right mouse button on to move in the area, wether to go more right or left, i have to move opposite direction in order for it to move where i want to go. Same happens if i move up it goes down and so on.

Otherwise the game runs really smooth and everything works as they should.

Ubi-Raziel
02-20-2020, 11:44 PM
Hey there.

Apologies for getting back about this so late.

After reading my original enquiry i realized i didn't explain the whole issue as best as i could.

So here is proper explanation of the issue:

Normally the mouse works fine, i dont have controllers or anything, I've always used right click move when i move the map or the area i'm building on and currently it happens when i press right mouse button on to move in the area, wether to go more right or left, i have to move opposite direction in order for it to move where i want to go. Same happens if i move up it goes down and so on.

Otherwise the game runs really smooth and everything works as they should.

Thank you for a more in-depth explanation! I'm sorry for coming back to you a little late too.

Nothing else screams out to be that could be causing the issue. Please try a clean boot as Ubi-Orion suggested and let us know how it goes!

If the issue remains, it would be good for us to review your system files. We may be able to find some conflicting hardware or software.

MsInfo: https://support.ubisoft.com/en-GB/faqs/21216/
DxDiag: https://support.ubisoft.com/en-GB/faqs/21185/

Once the files are added to a support case, feel free to add the case number here.

All the best!

Banez86
03-10-2020, 03:32 PM
Hello.

I've made Clean boot and i launched Settlers 1, where the movement when going to left is still going right and vice versa.

I also discovered that when you have minimap open in Settlers 1 and you click right mouse button on, the movement is still on main map when it should be on the minimap since that is opened at the time of moving.

I have made a support case and linked the files into the ticket, case number is: 11053753

I have made a report of this in english and in finnish, i would primarily prefer this to be sorted in english.

Regards,
Banez

Ubi-Raziel
03-10-2020, 06:04 PM
Hello.

I've made Clean boot and i launched Settlers 1, where the movement when going to left is still going right and vice versa.

I also discovered that when you have minimap open in Settlers 1 and you click right mouse button on, the movement is still on main map when it should be on the minimap since that is opened at the time of moving.

I have made a support case and linked the files into the ticket, case number is: 11053753

I have made a report of this in english and in finnish, i would primarily prefer this to be sorted in english.

Regards,
Banez

Hey! It's good to hear from you again.

I have reviewed both of the files you provided. I've so far not been able to find anything conclusive that could cause this issue.

You have already tried a clean boot, but I'd like to emphasise the important of making sure any overlay software is disabled. This is the same for any peripheral software, so anything that allows the creation of macros or the adjustment of your button clicks.

Also make sure no extra peripherals are plugged in that you don't need.

We'll now leave this to the technical team to investigate for you. They will be able to look into this more in-depth and you can always come back to us if you need anything.

All the best!

Banez86
03-12-2020, 10:53 AM
Thankyou. I had no extra peripherals plugged in and i had all the software turned off.

Will wait for the technical teams response :)

Ubi-Cupcake
03-13-2020, 01:57 AM
Thanks for updating us and being patient Banez86. :o

hajistic
04-13-2020, 06:11 PM
Just to let you know, this is how the game works. Map scrolling is inverted compared to modern games. It was the early days of mouse control in games and they were finding their way I guess. Quite a few games worked the same. I think Transport Tycoon and Populous are both the same.