PDA

View Full Version : No interactions with water in editor



MadMotoMan
11-15-2019, 03:56 PM
Hey. I don't know if anyone else has run into this or may know why I've run into this issue but...
In the track editor my bike and rider have no interaction with base world water. They did when I first started the map I'm working on, but now don't and even when I create a new map it do not. I have updated the game twice since creating this map and am running current version since Nov.15
I turned off and back on water, terrain, sky etc. in visuals while checking out different aspects of the editor but unless that cause a bug I can't imagine why water stopped working.
When I save the track I'm working on it saves changes I've made but the "Date Created" does not update.
Water interactions in the main game maps and downloaded maps still work fine.
I've tried to offer as much detail as I can think of. Any help would be appreciated (I am still new to this game). :confused:

MadMotoMan
11-16-2019, 04:49 PM
-Update-
Placing a water effect item just under the surface where I need water works but is that how it's supposed to be done? Base world water is only visual?

Ubi-Raziel
11-20-2019, 05:00 PM
Hello!

This is normal behaviour as physics are disabled by default, however you should be able to enable this settings easily.

While you are in Track Editor you will see an option to enable physics on the bottom bar. Here is an example:

https://i.imgur.com/oNjs1Ly.jpg

This image was taken from a PC but we had a controller connected, which is why you can see console controls. I hope that helps!

MadMotoMan
11-20-2019, 05:32 PM
Thank you for your quick help, but I think there was a misunderstanding.
Physics on/off works fine. Water I place on the map works fine. Base world water (already on part of the default map) has no interaction with objects or bike and rider.