View Full Version : Game Glitch - Leonardo da Vinci

08-30-2010, 02:35 AM
Hi there, I'm playing Assassin's Creed 2 on the PC and I've got this glitch where the game stops. It's still early in the game where I take the broken blade kit to Leonardo da Vinci for him to fix with the scroll he uses to get the information. After he's done he wakes me up then tells me he must cut of my ring finger, after he tells me he's joking he gives it to me and then the a messages displays to press ? to equip the blade. Once I set my weapon to the hidden blade nothing happens. The game doesn't freeze or anything it just waits for something. I'v reloaded this scene many times and gets the same result. Can someone please help? Any way I can skip this scene?

08-30-2010, 02:43 AM
If you are PC user, press "2" button

08-30-2010, 04:51 AM
It's ridiculous how many people still can't figure out how to select their hidden blade. No wonder Ubi dumbed the game down so much.

08-30-2010, 05:37 AM
Lol game glych or user glych http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

08-30-2010, 05:39 AM
it's a glitch not a glych...

it's a user glitch cause ppl are so <STRIKE>dumb</STRIKE> smart they need us to work it out and help them

08-30-2010, 08:32 AM
Doesn't it say "Use your Hidden Blade" or something like that?

08-30-2010, 09:12 AM
easiest thing to do is set the hotkeys for your weapons (those you can set) to the number key-pad on the right side of your keyboard, that's what I did. My weapons are set like this:

Blade = NUM 1
Sword = NUM 2
Fists = NUM 3

I think i might have set number 4 to be the knives, can't really remember, since when i select anything but fists, sword or hidden blades, i use the weapon wheel

08-30-2010, 11:29 AM
Originally posted by SupremeCaptain:
Doesn't it say "Use your Hidden Blade" or something like that? From what I remember it does..

However these things can be missed...

Least the OP has the information they need now http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

08-31-2010, 02:17 AM
Thanks the "2" Button did the trick. I used the "Q" Button to change to the hidden blade. Ubisoft could have worked a little more on their details.

Got it working now so yay http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif