View Full Version : Game Breaking bug: The Prophecy: Holding amulet up to windmill does not work.

07-05-2019, 04:36 AM
Hi, I experienced a bug where I cannot complete The Prophecy, the problem is with the windmill puzzle. I have the amulet and the windmill aligned perfectly and it does not begin the next phase or anything it just acts as if I am not aligning it properly or don’t even have the amulet in my hand. I have tried every different possible "bug fix" or "way around the bug" and it still does not work. What I find weird is that I did this mission for my dad on his account and it worked fine, when I tried to do it on my account the exact same way it did not work. For clarification, I did not leave the area of the windmill while I was doing this mission.

This was all around four days ago. Today I have started a new game (on the same account) thinking it would resolve the issue but I was mistaken and it did not let me proceed with the mission. I have a video that I recorded on my xbox of the mission not working. You can see in this video I was following Ubi-Karls suggestion of spinning it one at a time and holding the amulet in the “correct alignment”. https://gamerdvr.com/gamer/juicy-sharky/video/76750777

I already submitted most of this on a different thread but i thought I should make a new thread, because after posting about a different bug (entities despawning) I got a pretty quick response.

Thank you

10-03-2019, 01:55 PM
Hi BadAttorney7201,

Apologies for the delayed response, thank you for reporting that to us.

Did you see UbiMorning's response in the main thread on this here (https://forums.ubisoft.com/showthread.php/2008571-Prophecy-mission-glitch)?