View Full Version : Still Cannot finish The Keeper and the Kyros after patch 1.30

05-27-2019, 08:47 PM
I have downloaded and installed version1.30 and still am unable to complete The Keeper and the Kyros. Kyros is still standing in the spto where the humans were killed and still will not move. I have attempted all the solutions that people have listed and he is still not moving. Patch notes said this was fixed, but obviously not. Very disappointing.

05-27-2019, 11:13 PM
Here is a link to a video of the issue: https://video-dfw5-1.xx.fbcdn.net/v/t42.9040-2/10000000_187471272156621_1544121647210954752_n.mp4 ?_nc_cat=100&efg=eyJybHIiOjQxMTAsInJsYSI6NDA5NiwidmVuY29kZV90YW ciOiJzdmV***QifQ%3D%3D&rl=4110&vabr=2740&_nc_ht=video-dfw5-1.xx&oh=f20c5495b9594d70f58d623856795bde&oe=5CECA292

05-28-2019, 02:48 PM
I am sorry to hear that you are still experiening this issue.

The update should have resolved this. Can you please check to make sure the update has installed correctly. You can do this by checking in the bottom right corner on the main menu screen.

If the latest update is installed could you please provide another video as the one provided does not work.

Could you also submit a support ticket and attach a copy of your save files. For information on how to obtain your save files click here (https://support.ubi.com/en-GB/Faqs/000039882).

Once you have created a support ticket can you reply in this thread with your ticket reference number.

I can then pass this onto the dev team to investigate further.

05-29-2019, 12:03 AM
Hello, I have submitted support ticket 08968987 for the issue. I have also uploaded a video of the issue to youtube.https://www.youtube.com/watch?v=PIxDU28DrHE

05-29-2019, 11:05 AM
We have a workaround which we hope will help.

Go to the drop off location (red square on marked in the image on the map) so Kyros can complete his objective and after the the next objective should appear allowing you to finish the quest.

Here are some images to help guide you: https://imgur.com/a/VynhzOi

Please confirm if this resolves your issue.

06-05-2019, 02:43 PM
Does not work.
Iím amazed this hasnít been fixed.

06-05-2019, 03:52 PM
I had the same issue. Kyros only followed me around instead of initiating the next step in the quest. I took him back to the location where we killed the Isu soldiers and ran in circles around that location and eventually (30-45 seconds of running around) dialogue began between Kyros and the misthios. This solved the bug as Hermes now appeared at the drop off location.