PDA

View Full Version : Game gets stuck on main loading screen.



JavaFTC
05-02-2019, 04:19 PM
Just starting doing it today. It connects to the ubisoft servers, then it gets stuck with the screen saying its loading with the gear spinning.
Been playing since launch with no issues.

ArM4g3dD0n80
05-02-2019, 04:33 PM
Just got the same problem, i tabīd out of the game with "alt+tab" and search the forum, after 10-15 mins i tabed back to game, and i was finally in the main menue.. dont know what caused the long loading time, but just "waiting" seems to help..

huntsman451
05-02-2019, 04:50 PM
Same thing happening to me currently. Loading splash screen comes up, hit a key to enter the map UI as normal and it just sticks on loading for ages. Normally takes about 5 seconds on my PC, but right now I tabbed out to post this and it's been stuck with the spinning cog "loading" message for about 5 minutes so far. Something broke, any ideas what has happened?

huntsman451
05-02-2019, 04:56 PM
Update to above. Took 8 minutes roughly to load the map UI.

Scruffy McGuffy
05-02-2019, 04:58 PM
Same here. On Steam. Was fine last night, which was after some Steam update.

EmptyBottle4
05-02-2019, 04:59 PM
same here.
Played ~2hours ago and everything was fine. Now i have this problem.

tnucami
05-02-2019, 05:03 PM
Also experiencing same issue, newly on PC. Took a little under 10 minutes to get past the "Loading 100%" thing at the start.

Kruepto
05-02-2019, 05:12 PM
Hello,

i bought the game yesterday. Could play 3 hours. But now my game is stuck in the main menu loading screen...

Stonie74
05-02-2019, 05:45 PM
Got the same problem here, to the point I uninstalled and reinstalled... Still the same, what's happening with this game lately? Still have stuttering in full screen too, but borderless window is fine....

Gcandy
05-02-2019, 05:53 PM
Ive got this problem too ... loaded fine last night and now wont load at all ( I haven't left it 10 mins cos I didn't think it would load so closed ) ..Is this a Ubi problem or Trials?

Gcandy
05-02-2019, 06:42 PM
got it working again on normal load time of about 2 mins after 9 restarts of the program

Scruffy McGuffy
05-02-2019, 10:29 PM
I just tried it for the first time since this morning and it was working as usual, so hopefully whatever it was got fixed.

Ubi-Raziel
05-03-2019, 04:22 PM
Hello everyone! I have seen some reports of this issue on all platforms yesterday.

Can you please confirm if the issue still occurs?