PDA

View Full Version : BUG Quest: Political Hack



PimpEmpire
04-21-2019, 12:46 PM
I slipped passed the patrols, and dropped off the book to the lighthouse. He says cough it up, I clicked onkay.

But the quest didn't complete nor did it give me any other follow up. it's now blank with a timer still for completing even though I completed.

Katje-Katrien
05-12-2019, 09:24 AM
This is a old thread but it is the only one I could find.
I had to search the forum for this one. Because I just encountered the same issue.
The quest for Baron von Malching.

But what I did was sending a ship to the target place at his harbor.
And then I tried to sail my ship out of the red zone where you have to drop the book at the lichthouse of Sir Archibald.
And this did solved the quest. So I got my reward.

So I hope this can help someone in the future.

Ubi-Mark.
05-12-2019, 11:56 AM
Hello Annoholics!

Sorry to hear that you had issues with this quest. I'll report it to the development team and very big thanks to @Katje-Katrien for sharing this workaround! :)

Katje-Katrien
05-12-2019, 12:01 PM
Thank you very much.
Always happy to help :)