PDA

View Full Version : Game freezes DXGI_ERROR_DEVICE_REMOVED



XXXSITH
04-20-2019, 04:10 PM
Hi guys,

I could play Anno 1800 for over 20 hours without any issues at very high graphics settings.

Since I destroyed the pyro ships in the campaign and were going for some enemy harbors the game freezes every time.
This normally happens, when I attack harbors with lots of ships (8+).

Screen freezes, I can still move the ingame mouse, music goes on playing. When I shut down the game, I receive the following error message:
IDXGISwapChain::Present failed with error DXGI_ERROR_DEVICE_REMOVED.
GetDeviceRemovedReason returned 0x887a0006.

I run the game on the following system:
Win7 64 Pro
core i5 2500k @3.3Ghz
16gb ram
RX580 graphics
DX11

I already installed the latest drivers for graphics and direct dx.
I already set the graphics to lowest settings, but the same issue occured.
I already repaired game files and tried other savegames, but this did not solve the problem.
I already changed the regedit TdrLevel from 3 to 0, but the game still freezes and then I cannot even get back to windows, but have to reset the whole pc.
Therefore I changed it back.
The freeze occures every time, when I try to attack harbors with many ships.

Do you have any advice how I can fix this issue?

Best,
Tealceed

UbiMorning
04-20-2019, 11:49 PM
Hi XXXSITH! I believe I have seen a few other reports of this issue. Could you submit your MSINFO and dxdiag files over a ticket? (https://support.ubi.com/en-US/Faqs/Details/kA030000000emSbCAI?name=how-to-submit-dxdiag-and-msinfo-files) I can pass this on for a deeper look.

XXXSITH
04-22-2019, 01:15 PM
I just sent both files at the to the support: Ubisoft Support Ticket: 08723600

Hope to get help soon :-)

Kind regards,
Tealceed

XXXSITH
05-02-2019, 02:04 PM
To all who might be concerned with the same issue.
Deinstalling and updating my graphics driver helped to resolve the issue.

Ubi-Trippn
05-05-2019, 03:21 PM
Thanks for letting us know what fixed this issue for you XXXSITH.

TheWarMarmott
08-25-2019, 03:23 PM
I have the same issue. Driver up to date with a Radion 5700 xt

Radeon Settings Version - 2019.0808.1917.34733
Driver Packaging Version - 19.30.01.29-190809a-345944C-RadeonSoftwareAdrenalin2019
Provider - Advanced Micro Devices, Inc.
2D Driver Version - 8.1.1.1634
Direct3D® Version - 9.14.10.01410
OpenGL® Version - 26.20.11000.13570
AMD Audio Driver Version - 10.0.1.12
Vulkan™ Driver Version - 2.0.99
Vulkan™ API Version - 1.1.113