PDA

View Full Version : DX 12 - Crashes.



Cover.Fire.
04-19-2019, 01:50 AM
Hey all,

My game has crashed twice now when using DX12, never crashed when using DX11. I enjoy the performance boost that DX12 gives, but the crashing sucks!!

Drivers are up to date on my GTX 1080 Ti."

"An Unexpected DirectX error occurred - IDXGISwapChain::Present failed with error DXGI_ERROR_DEVICE_REMOVED. GetDeviceRemovedReason returned 0x887a0006."

Thanks,

Kirk

dinon74
04-19-2019, 02:31 AM
Same issue also using DX12 with GTX 1080 TI. Intel i5-3570., 8g memory., Windows 10 pro 64bit
Thanks.

powerpilz
04-19-2019, 02:35 AM
I have the same issue. But also with DX11.

GTX 1080, Intel i7-6700k, 32gb memory, Windows 10 64-bit.

It occurs almost certain within one hour. I tried to change graphic settings but nothing helped.

SKATEATROUND
04-19-2019, 05:29 PM
I have the same issue, but with DX12 an another error message number: 0x887a0001 . the error come Always after i make a pause (Break) and until few minutes.

Also
GTX 1080 :D
INTEL I9--9900k, 32GB Memory, Windows 10-64bit, 1809 (17763-437)

TheBadFrag
04-19-2019, 06:47 PM
Same problem here with all the systems from me and my friends.

i9 9920X
2x GTX 1080 Ti SLI
64 GB RAM
WIN 10
Game on NVME SSD
3840x2160

i7 8700k
RTX 2080 TI
32GB RAM
WIN 10
Game on NVME SSD
3840x2160

i9 9900k
RTX 2080 TI
32GB RAM
WIN 10
Game on NVME SSD
2560x1440

i7 6700k
GTX 1080TI
16GB RAM
WIN 10
Game on SATA SSD
2560x1440

i7 6700HQ (Laptop)
GTX 1060
16 GB RAM
WIN 10
Game on HDD
1920x1080

We run different Windows versions and different drivers and we all get the same error sometimes even at the same time. We only play multiplayer.
Fix this ASAP! :(

UbiMorning
04-19-2019, 08:04 PM
Hey guys! Thanks for the report. Could you try a clean install of your GPU drivers (https://support.ubi.com/en-gb/faqs/000025720/Nvidia-Driver-Clean-Installation)? I know there is a similar DX12 crashing issue with TD2 that they are working to resolve, so it may be related.

TheBadFrag
04-20-2019, 12:22 AM
2 of the machines above have fresh Windows installations on them and still crash. So yeah it's not the drivers.

Just got another crash after 6 houres continuous multiplayer. Sometimes it crashes a lot and sometimes it takes a long time.

TheBadFrag
04-21-2019, 05:22 PM
And crash again after 5-6 houres multiplayer. :mad:

alexrwlaw
04-21-2019, 06:35 PM
I switched to DX11 which seemed to fix the problem (for a while), but it's started crashing again with the same DXGI_ERROR_DEVICE_REMOVED error.

I'm not reinstalling my drivers unless Ubisoft can document why that would be a solution. It's a bizarre request to just throw out there.

Very fun game otherwise!

TheBadFrag
04-21-2019, 07:28 PM
You don't need to reinstall your drivers because it does nothing. Switching to DX11 is not really an option as well because you already get below 10 FPS in the endgame with DX12. DX11 would make it more like a fast screensaver than a game that you can accually play.

Both RTX builds from my friends have fresh Windows on them and still crash.

Baggl90
04-22-2019, 10:56 AM
Same here, GPU Drivers are up to date,newest dx version installed.

With Direct X 11 its running better, but still with crashes.
The Problem here is that you lose about 15 fps.

Still playable but a fix would be awesome.

My System:

Win10 pro full updated
Z170 MSI Tomahawk
6600k @ 4,5 Ghz
Gainward 1070 @ 4104ram clock / 2075 GPU clock
16GB DDR4 Ram

Its running on a 3k solution and ultra high gpu specs with about 40-25 fps.

Greetz, Baggl

alexrwlaw
04-22-2019, 12:40 PM
Still playable but a fix would be awesome.


Not so much awesome as essential, and I don't agree with "playable". I spent 60 on a game that crashes frequently, losing my progress, so there's no point in playing the game in its current state.

Where's the dev update about this? Come on, guys, surely this warrants an urgent hotfix, unless you don't know how to fix it.

This is a very fun game when it works. I've been developing software for over thirty years and I know things aren't always easy, but please don't leave us in the dark.

Vanessa-Black
04-23-2019, 05:12 AM
I am having the same crash rarely as well and also having horrible FPS that fluxes all over the place. I have no issues on any other game and can play all games at max or nearly max settings.This is an issue with Anno that I have seen many other people report. Installing fresh drivers will not fix this and I uploaded my crash reports each time so the devs should have the info.

Win10
Intel I7-3770k overclocked to 4.5 GHz
Nvidia GTX 1070
12GB Ram

Asciana
04-24-2019, 10:15 PM
I too am having this problem

Win 10
i5 8600k (not clocked)
eVGA 1080
16Gb RAM

TheBadFrag
04-25-2019, 09:02 PM
And crash again after 1 hour. Patch did nothing.

TheBadFrag
04-25-2019, 09:11 PM
And now a crash after 8 minutes. :o Running real good.

mkdr
04-25-2019, 11:39 PM
Again 2 crashes for me, after the patch. Patch didnt fix this.

junclj
04-26-2019, 03:08 AM
Anybody face the problem of the game quit unexpectedly? I am facing this issue after the update. Sometimes was facing game freezing problem. I never face this problem before update.

Ubi-Mark.
04-26-2019, 08:55 AM
Hello,

Sorry to hear that. Can you please try the troubleshooting steps here (https://support.ubi.com/en-gb/faqs/000025947/Basic-PC-Troubleshooting/)

If the issue persists, could you please submit a support ticket on our Support Site (https://support.ubi.com/en-gb/Cases/new)
Please attach both of the following system files.
DXDIAG (https://support.ubi.com/en-gb/faqs/000021185/Sending-a-Dxdiag-to-Support/)
MSINFO (https://support.ubi.com/en-gb/faqs/000021216/Sending-a-msinfo-report-to-Support/)

Our Customer Support team will investigate this further for you.

chris-ho
04-26-2019, 09:08 AM
I'm only facing DX12 error when I pause the game

TheBadFrag
05-12-2019, 09:42 PM
When will this be fixed?
And don't tell me that that all the dev PC's don't crash on DX 12. They crash exactly as often! :mad:

Took_Mr_Power
05-13-2019, 07:29 PM
I have crashes with DirectX 12, too. Just wanted to add another entry to this list...

baraterek
05-13-2019, 08:53 PM
I played only 29h, but there was no crashes at all - game just works. GPU was little hot until I changed Lightning quality to Low (rest is High/Ultra).
I have 4790k (OC 4.5Ghz) + 16GB RAM + RTX 2080 and Win 10 Pro and I play on 4k Monitor.

Caladon349
05-14-2019, 03:38 AM
I was having this same issue, multiple freezes then crash. went thru various setting finally turned off the building info overlay "the little floating icons showing building status on all your buildings" and the problem seemed to have gone away. Could just be a coincidence with the timing, will know more tomorrow

dmdilks
05-14-2019, 08:13 PM
I played only 29h, but there was no crashes at all - game just works. GPU was little hot until I changed Lightning quality to Low (rest is High/Ultra).
I have 4790k (OC 4.5Ghz) + 16GB RAM + RTX 2080 and Win 10 Pro and I play on 4k Monitor.

The problem is with only Nvidia cards. I have played over 120 hrs no crashes or Directx problems. I too have a RX-590 8gb card. It isn't the game it is the drivers that Nvidia uses. There are many games out there with the same problem as this game with trying to play with directx 12.

baraterek
05-14-2019, 08:33 PM
The problem is with only Nvidia cards. I have played over 120 hrs no crashes or Directx problems. I too have a RX-590 8gb card. It isn't the game it is the drivers that Nvidia uses. There are many games out there with the same problem as this game with trying to play with directx 12.

Hmm ... RTX2080 is Nvidia Card and still - no problems.

Ravyn74
05-15-2019, 07:52 AM
No problems up until about 5 hours ago. I am now getting these crashes in both Anno 1800 and Far Cry 5. A report was sent each time.

Captainrave
05-16-2019, 09:03 AM
How is this still not fixed? The silence from Ubisoft on the matter is deafening.

dmdilks
05-16-2019, 11:24 AM
How is this still not fixed? The silence from Ubisoft on the matter is deafening.

They said there was going to be a fix?


https://forums.ubi.com/showthread.php/2054487-Patch-02-Patch-Notes-May-15th-2019

Captainrave
05-16-2019, 01:40 PM
They said there was going to be a fix?


https://forums.ubi.com/showthread.php/2054487-Patch-02-Patch-Notes-May-15th-2019

They lied.

Ubi-Redbeard
05-16-2019, 03:40 PM
Thanks for the updates on this issue.

Can you guys confirm if you're crashing in the game or when launching the game?

T-F-Mongoose
05-16-2019, 03:49 PM
Thanks for the updates on this issue.

Can you guys confirm if you're crashing in the game or when launching the game?

In-game crash this morning. Drivers up to etc.

irishsaint1981
05-16-2019, 06:52 PM
In game crashing, sent reports.

Windows 10 Home

Intel i7-7700k CPU @ 4.20 GHZ
Ram 16.0 GB
GeForce GTX 1070 SLI Enabled

DataX
05-16-2019, 07:40 PM
Game crashes ingame with DX12. Crash to Desktop.

dmdilks
05-16-2019, 09:04 PM
I just done some testing and mine is running fine with a GTX-1060 6gb card. Ran it for about hour with no issues other then the card running about 70c.

Plus I'm running drivers from 2017 too. The newer drivers has the Directx 12 bug in them. That is want I have read online. Try and run a older driver like back in the middle of 2018 or older.

My game ran fine with the driver that windows installed 2017. I don't like Nvidia cards have had many problems with them. But I just wanted to see if I would have a problem. I will test the newer driver to see if it does cause a problem.

osner1
05-16-2019, 09:07 PM
Same problem here.

In game crashes and sends error report.

I know my laptop is not up to specs, but the info might help solve the issue:

i7-8550U 1.80GHz
16 GB ram
Windows 10 home

cornish
05-16-2019, 09:17 PM
I might be lucky to get 3 hours of gaming but once the 1st crash happens I have to delete the save just to get past 5 min's of game play......

For me this has never happen'd before yesterdays patch....

Added info...

Yesterday was the 1st day of problems and so I updated all drivers and used nvidia to set gfx according to my rig ( please see below )

Option's tried.....verified files all come back ok.

ADDED added info

Until yesterday I didn't try sandbox ---- and this is where the crash's are now happening.

I have multiple quests from my minion's I mean town's folk :D that I have to abandon because it's not showing how many of X or where X even is on the map or even what X is! even tho I know from playing the campaign what I am looking for. Hound's and wild animal's seem to be the most constant that bug. This has happened in middle game in the campaign but not like it is now with the 1st minion quest bugging out.

PC spec's

OS win 10 64 // CPU Ryzen 7 2700X // GPU NVIDIA GeForce GTX 1060 6GB // RAM 16 GB // game running on SSD.

dmdilks
05-17-2019, 04:05 PM
One thing people are not looking at is that when you play. The video is at a point of overheating. If I just leave it run it will get into the upper 70c and higher. If I run MSI-afterburner and run the fan at about 65% it will stay in the middle 50c. This game has a serious problem with making the video card overheat.

Could this be the problems with the errors and everybody thinks it is Directx problem? When I'm using MSI-afterburner I can watch the temp on screen when playing. When you are over the island the temp goes up and when you are over the water it drops about 10c or more. A overheating card will give almost any problem.

Plus I have run this with a Ati card & Nvidia card. I have run it on windows 7 & 10. I have never had the directx 12 crash. On windows 10 I have run both cards and in directx 11 & 12. On windows 7 you don't have a option to run it in directx 11 or 12. You only have that option on windows 10.

TheBadFrag
05-18-2019, 11:19 PM
And still the same crash after the update. How hard can it be to make a game with DX12 that doesn't crash? :mad:

I think it's 100% a Denuvo+DX 12 Problem. We had no crashes in the beta.

junclj
05-19-2019, 12:49 PM
Crash again for patch 2, the game keep quit out then ask for send report.

T-F-Mongoose
05-21-2019, 12:15 AM
So do the Dev's have any update as to when this issue is going to be resolved? It's been a bit quiet on the topic since the 2nd update was released.

Some form of communication would great as many of us have tried every fix / trick or workaround in the book with no real result.

Yes, I could use DX11 mode but it runs like a turkey with no stable FPS to speak of. DX12 it sits at 140+ without a care in the world till it crashes that is.....

:confused::confused::confused::confused:

Padenk2015
05-22-2019, 12:57 PM
Atleast add a 1 min option to the autosave menu untill its fixed, not very amusing beeing thrown back 5 mins every few hours and having to check my actions ingame (getting supplies, fights , quests etc).

It's my first Anno and i love it but this bug makes it feels like gaming in the 90's plzzz fix it

SPINAL.TAP
05-22-2019, 09:21 PM
Hi,
I cannot even start the game, just straight drop into a black screen and the UPLAY title screen opens, this has now been doing this since the last patch.

Details.
Windows 10 Home (x64) Version 1809 (build 17763.529)
Install Language: English (United Kingdom)
System Locale: English (United Kingdom)
Installed: 16/05/2019 22:46:48
Servicing Branch: Current Branch (CB)
Boot Mode: UEFI (Secure Boot likely not supported by this UEFI

4.00 gigahertz AMD FX-8370 Eight-Core
384 kilobyte primary memory cache
8192 kilobyte secondary memory cache
8192 kilobyte tertiary memory cache
64-bit ready
Multi-core (4 total)
Hyper-threaded (8 total)

Main Circuit Board b

Board: Gigabyte Technology Co., Ltd. 990FXA-UD3
Bus Clock: 200 megahertz
UEFI: American Megatrends Inc. F2 07/15/2013

1748.85 Gigabytes Usable Hard Drive Capacity
616.61 Gigabytes Hard Drive Free Space

MAT****A DVD-RAM UJ8C0 USB Device [Optical drive]
TSSTcorp CDDVDW SE-208DB USB Device [Optical drive]

CT250MX500SSD1 [Hard drive] (250.06 GB) -- drive 3, s/n 1819E13BEF92, rev M3CR020, SMART Status: Healthy
Samsung SSD 850 EVO 120GB [Hard drive] (120.03 GB) -- drive 0, s/n S21UNXAGB55228F, rev EMT02B6Q, SMART Status: Healthy
ST1000DM010-2EP102 [Hard drive] (1000.20 GB) -- drive 2, s/n Z9ANN64H, rev CC43, SMART Status: Healthy
ST3500413AS [Hard drive] (500.11 GB) -- drive 1, s/n Z2A7LP9W, rev JC4B, SMART Status: Healthy

16350 Megabytes Usable Installed Memory

Slot 'Node0_Dimm0' has 8192 MB (serial number 1B2EC61B)
Slot 'Node0_Dimm1' has 8192 MB (serial number 1A2ED51B)
Slot 'Node0_Dimm2' has 8192 MB (serial number 152ECD1B)
Slot 'Node0_Dimm3' has 8192 MB (serial number 1E2ED61B)

Local Drive Volumes



b: (NTFS on drive 1) 500.11 GB 282.50 GB free
c: (NTFS on drive 2) * 998.69 GB 84.49 GB free
g: (NTFS on drive 3) 250.06 GB 249.62 GB free


* Operating System is installed on c:

AMD Radeon (TM) R9 390 Series x2 [Display adapter]
Samsung C32F391 [Monitor] (31.5"vis, s/n 0PCQHTQJC01078, December 2017)

Sorry this is the best I could copy paste for you on my rig.
Please can you fix this asap, I also have ANNO 2205 which runs fine

Yors

SPINAL-TAP

LeaWildcat
05-23-2019, 10:28 PM
This helped me and you guys are more than happy to try it and see if it helps. First, shut down any hosting software like GOG, Discord, Steam/Epic (unless you have the game there), Windows Game mode, etc. Next turn off in-game notifications in Uplay and Steam/Epic especially pertaining to your friend's list. Third, turn off, disable, uninstall any tuning software. I uninstalled my ROG Gaming Center and it runs so much cooler now and not eating RAM or decreasing FPS. If that doesn't help, turn off the overlays and launch the game in offline mode. If you have Steam or Epic, you will have to do those as well. Also be aware that NVidia GeForce will "optimize" the game every time it updates, unless you uncheck that option. If all else fails back to DX11.

When the game came out, I didn't have a problem, then after the 1st patch, I was like y'all and couldn't play and discovered the overlay-offline solution. After the 2nd patch, I was okay until Steam updated the Friend's console and back to crashing. Discovered the above hints and tested it today that most of my problems were notifications of my friends coming and going, their achievements, and even a notice from Steam that games in my wishlist were onsale crashed me. I have to have Steam to launch the game, but I usually launch Steam, go offline, and then launch the game from the Uplay host. I get a black screen at the front saying "Anno7" not responding but then just leave it alone and the game loads.Hope it helps.

My Specs: ASUS ROG Strix GL703VD, i7-7700HQ, 2.80GHz; 16GB RAM; NVIDIA GeForce GTX 1050 4GB RAM; intergrated with Intel Graphics HD

dmdilks
05-24-2019, 04:04 PM
My Specs: ASUS ROG Strix GL703VD, i7-7700HQ, 2.80GHz; 16GB RAM; NVIDIA GeForce GTX 1050 4GB RAM; intergrated with Intel Graphics HD

On your Laptop what are you running for a hard drive? If it is a 1tb most of the times they are only a 5400 rpm drive. They are a piece of crap. I know somebody playing a online game. She was having all kinds of problems. She was running a 1tb 5400 rpm drive. She was able to install a SSD and all her problems went away. Plus she had basically the same laptop.

LeaWildcat
05-24-2019, 09:11 PM
500 GB SSD it's the only way to go

dmdilks
05-24-2019, 09:18 PM
500 GB SSD it's the only way to go

Is it a reg SSD or a NVMe drive?

LeaWildcat
05-25-2019, 05:50 PM
Just standard. At the time I got my system the biggest NVMe drive was 250

TheBadFrag
05-27-2019, 04:38 PM
I guess the crashes will not get fixed?

...pumping out DLCs seems way more important than a game that you can actually play. :rolleyes:

T-F-Mongoose
05-27-2019, 06:13 PM
Feels like it, opened a ticket, got a reply in 24 hours with "basic" guidance" to fix the issue i.e. update your drivers, re-install the game etc.

Not to sound funny if they had read my support ticket they could have saved themselves some time, as I listed down every fix/tweak/update I had done up to that point to fix the issue.

Sent a reply back, 4 days and counting and no reply back.......