PDA

View Full Version : Language keeps switching



gOurra
04-16-2019, 08:47 AM
I just started playing the campaign and the game keeps changing language at random events. Every time this happens I have to choose the next language in the list to show the game in English again (and the English option change to something different every time). While it doesn't make the game unplayable it's really annoying.

Ubi-Swaggins
04-16-2019, 11:10 AM
Hey gOurra,

Thank you for the report.

Can you provide a video or screenshot of this in action, so we can get it looked into?

Cheers

MorbiusStorm
04-16-2019, 11:44 AM
Same here. Just play the campaign. After a 10 min my language switched from English to Spanish.

Ubi-Swaggins
04-16-2019, 11:52 AM
Hey MorbiusStorm,

Did you manage to capture any video footage of this?

MorbiusStorm
04-16-2019, 01:07 PM
Nope, didn't know it was going to do it. It seemed triggered by an quest/event. Only happened once. Fairly early on. I think it was the start of the prisoner thing. Looked up and it was all Spanish. Restarted to get it back to normal.

Ubi-Swaggins
04-16-2019, 02:15 PM
Okay, thank you for the information.

I will pass this along, if you encounter this in future, please record a video of it and send us it :)

MorbiusStorm
04-16-2019, 08:08 PM
Let me add that the game probably thought it was in English still. The first thing I did was go into setting and try to set it back to English. But button didn't work at all. Like it thought it was already in English and didn't register any change of state pushing the button. I probably could have fixed it by selecting a different language, and then setting it back to English. That did occur to me. But I wasn't going to keep playing if there was some kind of corruption. I wanted to make sure my game would loan back up correctly. So I didn't even bother just trying to save/reload. I saved, extied completely, restarted, and then loaded it up. All was fine after that.

MorbiusStorm
04-16-2019, 08:19 PM
One theory I have is that reloading a game may even prevent the problem. I didn't see it again. After probably three more hours of game time after my save/restart/load. So it could have something to do with the initial state of the settings after install. Perhaps they haven't been saved or some pointer wasn't set to its default. The theory is that in that fresh install state it happens. The first OP said he solved differently from me and that it kept happening to him. He mentioned he chose the next one in the list to get it back to english. My save/restart/reload may have then saved the settings to english so going forward I don't see it anymore. Anyway, just a working theory based on me not seeing it again and the OP saying it was repetitive for him, combined with the two different ways it was solved.

MorbiusStorm
04-16-2019, 08:27 PM
And I just realized one last thing. Mine did come back up in English after loading it again. So despite that it was showing everything in Spanish, it did save the setting to English when I saved it. Then on reload it came back up in English, not Spanish. I didn't have to go in and change it to English after reloading it. So it would seem apparent that it did indeed think it was already set to English, despite that it abruptly changed to show everything in Spanish. Seems likely that either a new game or only a new game started from new install is where this will be seen. But you never know. Intermittent may mean I just got lucky and didn't see it again that session.