PDA

View Full Version : BUG: Falsche Fraktion nach Savegame Load im Multiplayer



CrushL
04-13-2019, 04:25 PM
Hallo,

wir hatten gestern folgendes Szenario:

Spiel wurde mit 3 Spielern und einem Computergegner gestartet. Ich war auf dem 3. Slot. Nach 2 Stunden ging dann der Spieler, der auf dem 2. Slot war, schlafen und wir spielten zu zweit weiter. Nochmal 2 Stunden später hatten wir einen desync und das automatische System blieb im Ladebildschirm hängen. Also gingen wir ins Hauptmenü und der Host startete das Savegame. Ich konnte auch ohne Probleme in die Lobby (wieder auf dem 3. Slot angezeigt. Der 2. Slot blieb leer).

Als wir dann das Spiel starteten, hatte ich keine Kontrolle mehr über meine Inseln und Schiffe, sondern über die von dem Spieler, der 2 Stunden vorher gegangen war (der auf Slot 2). Wir haben dann versucht, dass ich das Spiel hoste aber egal wie wir es drehten, ich wurde immer auf die Fraktion des Spielers gesetzt, der nicht mehr da war. Im Menü wurde ich allerdings weiterhin als der Charakter angezeigt, den ich ursprünglich hatte. Nur eben im Spiel selbst dann nicht.

Ist jetzt nicht so wahnsinnig dramatisch, da wir im finalen Spiel wohl ein neues Savegame zu zweit angefangen hätten und damit das Szenario so nicht aufgetreten wäre. Ich wollte es aber dennoch mal reporten :-)


Grüße

purzlschn
04-13-2019, 05:11 PM
Ja, genau so ist uns das auch passiert. Wir waren zu viert. Neues Multiplayer gestartet, der erste Spieler verabschiedete sich nach 45 Minuten. Dann zu dritt weiter. Der zweite Spieler verabschiedete sich dann irgendwann zwischendrin und ich musste mein Spiel neustarten, weil ein DirectX-Fehler auftauchte und das Spiel abgestürtzt ist. Neu gestartet, neu eingeladen, alles im Menü wie immer, ich bin aber trotzdem immer noch der, der zuerst gegangen ist. Bei uns ist es auch ganz egal wie wir das drehen und versuchen. Ich hab meine schöne Stadt verloren. Guuut, halb so wild, ist ja nur die Beta. :-D