PDA

View Full Version : Black screen & crash just after launch



AlphaDreams
04-13-2019, 04:19 PM
Hello,

I know that there are several posts here about this issue, but I can't find anything that resolve my case.
When I click "Play" in the Uplay Launcher, a window called "Anno 7" appears, then a black screen, and after 10 seconds I go back to the desktop.
There is no error code.

I tried to reinstall the game, to check the game files, to switch to DX11 in the engine.ini file, launch as administrator both Uplay and the game, but nothing works.

Here are some useful files :

(It's quite heavy, I can't paste it directly into this post, sorry)

DxDiag : Pastebin (https://pastebin.com/K1eJ38rx)
MSINFO : Firefox Send (https://send.firefox.com/download/c051dfe97f446829/#C3O8jnPn4YygiFWDBJL9ig)

The last Log of the game :


[14:56:33][3410][ NOTICE] rdgc::CGameClient::Run: Developer build - for internal use only! [Build: 2019-04-11 14:57:27] Anno7 UPlayOpenBeta Win64 Release-Static v1.0.861139.1428 OpenBeta
[14:56:33][3410][ NOTICE] rdgs::CInitFile::GetDefaultLanguageFromRegistry: Set game language to en-US
[14:56:33][3410][ NOTICE] rdgc::CGameClient::InitBaseSystem: Starting initialization with working directory 'C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Anno 1800 Open Beta'
[14:56:33][3410][ NOTICE] rdgs::CInitFile::GetDefaultLanguageFromRegistry: Set game language to en-US
[14:56:38][3410][ NOTICE] rd3d::COutputWindow::Create: Display 0: 1920 x 1080 resolution
[14:56:38][3410][ NOTICE] rd3d::COutputWindow::Create: Clamped resolution: 1920 x 1080
[14:56:38][3410][ NOTICE] rd3d::CAmdGpuServices::InitLibrary: Failed initializing AMD GPU Services (return code 4; this is fine for machines with a non-AMD graphics card)
[14:56:38][3410][ NOTICE] rd3d::CDevice3D11::Create: Created DirectX11 device with feature level 11.0
[14:56:38][3410][ NOTICE] rd3d::CDevice3D11::Create: Number of GPUs: 1
[14:56:38][3410][ NOTICE] rd3d::CAftermath11::Create: Successfully initialized NVidia Aftermath
[14:56:38][3410][ NOTICE] rd3d::CShaderManager::InitDirectories: Effect file root dir: ''
[14:56:39][3410][ NOTICE] rd3d::CSessionManager::CreateSession: Created session ID -1:'Default'
[14:56:40][3410][ ERROR] EalLogOutput: [EAL]: This platform has logs enabled. Don't use it for shipping.
[14:56:40][3410][ ERROR] EalLogOutput: [EAL]: This platform has traces enabled. Don't use it for shipping.
[14:56:40][3410][ NOTICE] rdgs::CAccountSettings::Reset: Language returned by UPlay: "en-US"


Thank you !

UbiMorning
04-13-2019, 06:57 PM
Hi AlphaDreams! Thank you for the links. I found it strange that the logs say it was set to EN-US, when both your account language and language in your DXDIAG files said French. Do you have the Uplay client sent to English?
In your DXDIAG files, I noticed "spacedesk Graphics Adapter" under your Graphical devices. Could you try disabling that?

AlphaDreams
04-13-2019, 07:36 PM
Well, in the game settings in the launcher, it seems that the game language is set to English.
I just tried to set it to French, and I completely removed spacedesk, it's not showing in the peripheral manager anymore.

But the game still crash...

I opened a bug report on the ubisoft support site (n08592590, but it's in French), with the files that I send in the previous post, just in case.

Ubi-Trippn
04-14-2019, 09:17 AM
Hi AlphaDreams, Looking at the MSINFO it looks like Uplay is crashing rather than the game, due to Gdi32full.dll. This is a library for Microsoft graphics device interface so there could be an issue with GPU drivers or the Windows version as it is not the most up to date.

It also could be a that the supporting software is also out of date. usually the installers for the supporting software come with the game on Uplay.
They would be found in the games directory on the hard drive.
C:\Program Files (x86)\Ubisoft\Anno 1800\support\software
*For example ( I am not certain of the Open Betas exact directory path)

AlphaDreams
04-14-2019, 12:04 PM
Well, it's weird, I thought I've got the last version of Windows, but I found a new one in the windows update panel (maybe an optional one ?)
After updating, I can finally launch the game !

Thank you for the advice !

Ubi-Trippn
04-14-2019, 03:02 PM
Glad to hear it, thanks for the update.
Hope you enjoy the game!

Thorgat
04-14-2019, 11:07 PM
I have the exact same issues. No Windows update available for me though. Windows 10 Home 64 bit, Geforce GTX 960, AMD Phenom II X6 1055T.
I've submitted the files in the ticket section.

Thorgat
04-14-2019, 11:09 PM
Ticket is 08604012.