PDA

View Full Version : Friend doesn't see Store or 'Anno 1800 Open Beta' Tab in Uplay Launcher



SirPenetrat0r
04-12-2019, 10:58 PM
Update:
So I had to go through the forum and randomly stumble over a post "Want to play beta now!" (https://forums.ubi.com/showthread.php/2037051-Want-to-play-beta-now!) and come by the Message of the User LadyH.

Through this link: https://register.ubisoft.com/anno-1800/en-US it was possible to finally get the game into his Library and make the 'Store' & 'Anno 1800 Open Beta' Tab appear.

Quite a challenge if you never really use Uplay Store or aren't "tech savvy" to google the Stuff yourself even though it is an "Open Beta" and should be easy to access. Or am I missing something here'?:confused:
For me personally it worked without problems though - but I also bought some games in the Uplay Launcher, so there's that.

*puts on tinfoil hat* Maybe Ubisoft doesn't like Users who only have the Uplay Launcher because/for Steam?
--------------------------------------------------------------------------------------------

Hello Everyone,

I just told my friend that the Anno 1800 Open Beta is live. He downloaded the Uplay Launcher and logged in with his Uplay Account (not a new one).
The strange thing is he can't see the 'Store' or the 'Anno 1800 Open Beta' Tab. His account is activated + 2 Factor Auth.

Even when he opens this link: https://www.ubisoft.com/en-us/game/anno-1800/
And clicks on "Play Now" where it should launch the Setup in the Uplay Launcher it opens the 'Activate Product' Tab for him where he has to enter a key.
He also already tried closing / reopening the Launcher
Why isn't my friend able to install the Open Beta?

Thanks for any help...

RebaChew
04-13-2019, 12:35 AM
I had the same issue and I found this, after clicking on it , the game showed up in my uplay "my games", then I had to DL it. Hope this helps.
https://register.ubisoft.com/anno-1800/en-US

SirPenetrat0r
04-13-2019, 09:46 AM
Hey man,

thanks for your input but I already stumbled over the link beforehand somewhere in the forum.

Thanks again! :)

UbiMorning
04-13-2019, 06:02 PM
I am glad you were able to figure it out SirPenetrat0r!