PDA

View Full Version : Trials Rising not starting anymore - EAC untrusted system file secur32.dll



icex42
04-11-2019, 01:24 PM
Hello,

When I am trying to launch the game through steam or through uPlay I get the error from Esay Anti-Cheat "Untrusted system file (C:windows/system32/secur32.dll". I have tried uninstalling and repairing the easy anti cheat application from the Trials Rising folder and it didn't help. It is a bit weird since the game ran fine before, but I can't find a fix for this now.

I have also opened a Ubisoft support case: Ubisoft Support Ticket: 08578798 with the MSinfo.txt and DxDiag.txt files attached for easier troubleshooting.

Things I have tried to fix it:
- repairing and reinstalling the anti cheat application for Trials Rising
- restart the computer
- running all possible windows updates
- running SFC /scannow command in the CMD to try and possibly find any corrupted/missing .dll files and it finds no errors in the log
- restarting steam
- reinstalling Trials Rising a few times
- verifying the game files through steam
- updating the graphics drivers

Please let me know about any solutions asap, since I can't play the game at all and it's very annoying.

icex42
04-12-2019, 09:57 AM
Anyone have any ideas? I'm also wondering how long does ubi support usually take to respond?

PhutureProof
04-16-2019, 07:50 AM
Hey there brother

I am not experiencing this issue but I did a google and someone else on the ubi forums has found a work around, hopefully it helps

https://forums.ubi.com/showthread.php/1860531-untrusted-system-file-(c-windows-system32-secur32-dll)

PhutureProof
04-16-2019, 07:54 AM
Also this may help, couple of suggestions here

https://www.epicgames.com/fortnite/forums/technical-support/hardware-support/330167-untrusted-system-file

UbiMatcha
04-18-2019, 11:55 AM
Thanks for sharing PhutureProof!
I'd also recommend running Steam, Uplay, and the game with admin rights (https://support.ubi.com/en-GB/faqs/000025662/Run-applications-with-administrator-rights), as well as white-listing these on any antivirus software.