PDA

View Full Version : Liberation Crashing



Ainvar82171
04-07-2019, 02:22 PM
I have a PS4 Pro and I have had Liberation crash twice, anyone else having this problem? First time was sequence 1 going into the governor's mansion and the second time in sequence 2 after killing the guards in the swamp, (the ones after the smugglers hideout) and going for the chest.

Ubi-Keo
04-09-2019, 10:42 AM
I am sorry to hear that you are experiencing this issue.

As you are playing on a PS4 Pro please make sure that the boost mode is disabled in the PS4 settings and launch the game again. If the issue persists please try the following troubleshooting steps if you haven't already done so:

1. If you have a disc version of the game check to make sure there are no marks or scratches on the disc. If the disc is dirty clean it with a lint free cloth.
2. Delete the games install data.
3. Rebuild the database (https://support.us.playstation.com/articles/en_US/KC_Article/Safe-Mode-PS4/) on your PlayStation 4.
4. Reinstall the game and download the latest patch update then try again.

SKR_666
04-11-2019, 08:08 AM
I'm having the same issue as well, it crashed on me three times. I will try those trouble shoot methods through and see if that fixes it.

Ubi-Keo
04-11-2019, 11:05 AM
@SKR_666 I'm sorry to hear that you have also experienced this. Could you please confirm if the troubleshooting steps provided help to resolve the issue.

Thanks

Ubi-Keo
04-11-2019, 05:50 PM
Hi guys,

Can you confirm if you had started playing Assassin's Creed 3 before you started Assassin's Creed Liberation?

stewgee
04-12-2019, 04:53 AM
I'm having the same problem with Liberation crashing on a PS4 Pro, always within the first five to twenty minutes of the game. I tried deleting and then downloading the game again, but it only crashed when I was picking up the traveling clothes instead of after chasing the chicken.

I guess I'll try the steps above, even though I've been through the process of reinstalling the game. I'm trying to play Liberation first. I've already played AS3 a couple of times, I've never finished Liberation.

Ubi-Keo
04-12-2019, 11:55 AM
@stewgee I am sorry to hear that you are experiencing this.

To confirm have you played Assassin's Creed 3 Remastered on your PS4 before you launched Assassin's Creed Liberation? Or did you mean that you had played Assassin's Creed 3 in the past on another console/PC?

If the issue still persists after following the troubleshooting can you try disconnecting your PS4 from the internet and try launching the game again in offline mode to see if that helps.

Can you please update this thread once you have tried those steps.

Thanks

stewgee
04-12-2019, 08:31 PM
I meant that I played AC3 on other systems before so I went ahead and started Liberation first on PS4.

Disabling boost mode seems to have worked, I've played about 45 minutes without any problems. I'll try the other steps if the game continues to crash.

Ubi-Keo
04-16-2019, 10:52 AM
@stewgee Thanks for the update.

I am pleased to hear the game has not crashed so far since disabling boost mode.

Ainvar82171
04-22-2019, 11:48 AM
Disabling Boost mode did not work for me. What did work, which I found in another forum on another site. Turn off the internet connection to the PS4 Pro. I played hours with no crashing. I turned on the internet connection to update trophies. I forgot to turn it off again and the game crashed again.

UbiMorning
05-02-2019, 09:04 PM
Thanks for sharing Ainvar82171!