PDA

View Full Version : [AC3] Missing Bow and Arrows



NineHurdle23193
04-01-2019, 02:05 AM
Around sequence 5 I lost my bow and arrows during a combat sequence. I thought restarting the game would get it back but it didnít work. I even tried reinstalling the game but it still didnít work. The quiver is still on Connorís back but there are no arrows and I canít equip the bow in any way. Any help would be appreciated.

UbiCosmos
04-01-2019, 02:10 AM
Hello NineHurdle23193,

Welcome to the forums! What platform are you playing on?

Please feel free to reach out to our Support Team Here (https://support.ubi.com/en-US) so that they can assist you directly.

NineHurdle23193
04-01-2019, 03:14 AM
I am playing on Xbox One

General.lareneG
04-04-2019, 02:20 AM
same here, on pc
Well done ubisoft for shipping a buggy remaster.

Btw if someone knows how to get it back i would appreciate because among all the bugs this one is pretty annoying.

Ubi-Keo
04-05-2019, 11:59 AM
Hi guys,

I am sorry to hear that you have experienced this issue. Could you please provide a video to show that the bow is missing and cannot no longer be equipped.

Could you also try the following workarounds:

1. Go back to the Homestead, into the basement and try retrieving the bow from there.
2. Replay Sequence 9 Part 2 (The Foam and the Flames) and try equipping the bow again after this mission.

Please confirm if any of these workarounds help.

LUR21
04-06-2019, 09:13 AM
I have the same problem and already have a case open with the team so they must be aware of the issue. As i can't record gameplay on my PC here is a link from the original AC3 that has the exact same problem I have.

https://www.youtube.com/watch?v=_231EScqpec (https://www.youtube.com/watch?v=_231EScqpec)

The bow is not in the armory downstairs basement. Never has been in Remastered or Original. I have also tried sequence 9 Part 3 (which is The Foam and the Flames) a number of times and has had no effect on the glitch. Have tried verifying files and even re-installing which also had no effect.

General.lareneG
04-06-2019, 05:14 PM
Those workaround doesn't work or me neither, same as above.
Funny because this bug was there in the 2012 original version with the memory thing as workaround.

Time saver: start a new campaign then go to the chapter were connor uses bow for hunting doesn't fix the issue on your main campaign.