PDA

View Full Version : Permanent fix for Windows 10 Laptop Low FPS (with Nvidia switchable graphics)



Kektous
03-15-2019, 10:30 AM
First off, make sure your graphics card meets the minimum requirements for the game. If you're getting low FPS, even tho Trials Rising isn't THAT intensive, it could just be that you have too weak of a graphics card.

Go here to check: https://www.systemrequirementslab.com/cyri/requirements/trials-rising/17901 (Pressing "Can I Run It" will download a detection tool that will study your computer hardware and check if you can run it)

Now that this is out of the way, here's what I did to get it working (In the best order I can remember):

1. Make sure your laptop is on HIGH PERFORMANCE battery mode. Do this by clicking the battery in the task tray and going to power options.

2. Update your Nvidia drivers, and don't hesitate to restart afterwards, sometimes that helps.

3. Right click your desktop and access Nvidia Control Panel. Click on "3D Settings" from the lefthand menu, select the program settings tab. Here you will have to browse and find the .exe of the game. This can vary based on where you bought the game, but for steam it goes as follows: /Program Files(x86)/Steam/Steamapps/Common/Trials Rising/datapack. Your trialsrising.exe should be there, add that to the program settings list in the nvidia panel, then set it on the High Performance GPU.

NOTE: Right before the datapack folder (/Program Files(x86)/Steam/Steamapps/Common/Trials Rising) there is a LAUNCHER by the name LAUNCH_TRIALS_RISING. Do not confuse this with Trialsrising.exe, however it does not hurt to add BOTH OF THEM to the nvidia program settings and setting the GPU to high performance.

4. THIS IS THE MOST IMPORTANT STEP(This was the step that finally got it working for me):

- Right Click your desktop and go to display settings, NOT nvidia control panel. This should pull up a settings window. Click on "Graphics Settings" at the bottom of the page. Keep "Classic App" selected, and hit browse. Just as you did in step 3, ADD BOTH the trialsrising.exe and Launch_Trials_Rising here. Afterwards, click on them when they appear in the list and hit "Options". Windows will prompt you with 3 choices, obviously set it to high performance.

That should make your game use your high performance GPU, therefore fixing fps.

I believe there is a conflict between windows 10 and trials rising, because normally all you need to do is to set it in the nvidia control panel and it works. For some reason, by default, windows 10 puts trials on power saving mode. Hopefully this info can help the devs get to the bottom of this, and I hope I managed to help you guys fix it on your ends.

UbiMatcha
03-15-2019, 05:31 PM
Welcome to the forum kektus88!

Thanks for sharing your workaround!

ST1CKM4Nbeni
03-17-2019, 10:12 AM
Windows 10 Home
i5-6300HQ
GTX 960m

This workaround is very effective for me, finally getting stable 55~60fps in every tracks! Thanks Kektous so much!

However consecutive huge terrible stuttering, tearring and lags are still troubling on my run. But I heard these problem is occuring on every platform.
I think this is coused by copy protection tech, such as Denuvo you know. So could you Ubisoft address the problem somehow, even just a little?

pat_supreme
03-19-2019, 10:33 AM
Thanks! Solution works for me!
Still think so many weeks after release it's lame the devs haven't released a patch for this.
I enjoy the game although :)

purpazo
03-22-2019, 03:48 PM
thanks alot for the workaround! i will try and confirm