PDA

View Full Version : A bit too eager frustrum or occlusion culling



LasseVK
03-13-2019, 09:56 AM
While just freeroaming I happened upon a spot on the map where while I exited a alley I noticed that graphics was not being fully rendered. It seemed that frustrum or occlusion culling was having a trip. Perhaps both? Perhaps they had given up in the face of the apocalypse and was having a party.

Anyway, here is a video of the incident:
https://xboxclips.com/LasseVK/af5193ae-19ee-4fe6-8177-2c594e6ceec1

At the end I pop open the map so if you pause it you should be able to exactly where I was when it happened.

This was unrelated to anything in particular that I could remember, so I didn't just load into the game, view a cutscene, finish a fight, or whatever, I was just out loot... running, I was running.

I did not restart the game and try again as this was just at the end of my gaming session so I have no idea if this is a permanent problem or a one-time incident.

UbiMorning
03-13-2019, 05:36 PM
Hello LasseVK! Thanks for the report. Was that the only area that you saw that happen? What model XB1 do you have?

LasseVK
03-14-2019, 01:11 AM
I have only experienced this problem in this specific alley.

I retested it just now, it still does this, so it doesn't seem to be a one-off thing. This time I loaded into the game, and went straight for this alley. Still happens here. This time around it was night-time in the game, previous time it was day-time.

The problem also happens if I exit the alley, and stand between the alley exit and that large truck visible in my video, and look back into the alley. Now it is the alley and the walls of the buildings that are disappearing.

Here's a video of tonights test
https://www.youtube.com/watch?v=KtEW9da5Ztg

I have an Xbox One X.