PDA

View Full Version : Colour event bug



H3X23
03-09-2019, 05:07 PM
I have a sequence of 8 colour changes each delayed by 5 seconds, it has worked on one object, I have tried to copy and paste the same logic to use on the same type of object but in a different place and it only goes through the first 2 changes and then stays at that colour even though the impulse is going through and triggering each one like it should.

The first one I built still works as intended but any more I try to build from scratch or copy and paste just get stuck on the second colour.

JolanXBL
03-18-2019, 08:07 PM
The first time I tried copying a physics joint, it ended up breaking while testing, so since then I just assumed not to copy anything and create a new tool card each time.

If the option is there, try converting it to a Function before copying.

H3X23
03-19-2019, 03:53 AM
I have tried building it again but it didn't work. Ended up having to build it a completely different complicated way for the rest of the objects. What does converting it to a function do? I still haven't seen what that does

JolanXBL
03-21-2019, 08:28 AM
Converting a bunch of code to a function sort of zips them up into a couple of toolcards like IN, OUT, and the main bundle.

I don't really know why being able to do that exists, I've never found a use for it other than creating an empty function just so I could rename it like a label for my chunks of code.

So I'll create a variable data source, convert it to a function, and then change its name to 'move the legs' or ' weapon script'.