PDA

View Full Version : HELP: Lag Spikes in borderless/windowed and terrible screen tearing in fullscreen



ImDempsey
03-09-2019, 08:51 AM
So I have been playing in borderless and windowed mode since the release of the game and I have over a hundred hours already in which I was having no issues. Yesterday when I opened the game and starting playing I immediately was getting random fps drops no matter where I am in the game, menu or in game. It makes it unplayable. I have tested lots of stuff and can not find a solution or understand why this is happening... The fps drops stop when I turn on vsync, however I can't play on vsync because of the input lag, so that isn't an option. Something else that stops the lag spikes is going into fullscreen. The issue with this is that it causes extreme screen tearing.

Want to mention that the fps counter I have in game stays at 60 even when it clearly is not 60.

I do not know what to do. I play at a high level, so I can't afford to play with input lag, so vsync is not an option unless there's a way to remove the input lag. I need to fix the random lag when in borderless/windowed or I need to fix the screen tearing when in fullscreen.

I have had no windows updates or driver updates, so this isn't the problem.

My monitor is also 60hz, so I don't see why vsync is causing screen tearing.

I also completely factory reset my computer today because I am desperate for something to fix it. Well, that didn't change a thing. No change in the fps drops or screen tearing. So I am very confused and need help (I'm need to fix this:()

I also have no issues in any other games. I tested 4 different games today, including trials fusion.

Also want to mention that my cpu/gpu/ram usage is normal, not maxing out or anything.

If somebody can fix this for me I will literally send you $150 paypal (no joke)


CPU: Intel i7-6700K

RAM: 16GBs

Windows 10 64bit

GPU: Geforce GTX 1070

Znakemaster
03-09-2019, 12:10 PM
Have you tried this fix, it was posted in the forums. On the desktop, right click and hit "Display Settings". Scroll down and click "Graphics Settings". On the drop down menu select "Classic Apps". Browse and find trialsrising.exe (Steam/SteamApps/Common/Trials Rising/datapack/trialsrising.exe), click it and add it. Back at the graphics setting screen click the newly added trialsrising.exe and click options. Select "High Performance". Click save.

One of my friends also had problems with fps and he also plays in borderless and had to resort to v-sync to get it to run smoothly, as did i.

ImDempsey
03-09-2019, 09:36 PM
Have you tried this fix, it was posted in the forums. On the desktop, right click and hit "Display Settings". Scroll down and click "Graphics Settings". On the drop down menu select "Classic Apps". Browse and find trialsrising.exe (Steam/SteamApps/Common/Trials Rising/datapack/trialsrising.exe), click it and add it. Back at the graphics setting screen click the newly added trialsrising.exe and click options. Select "High Performance". Click save.

One of my friends also had problems with fps and he also plays in borderless and had to resort to v-sync to get it to run smoothly, as did i.

Tried this and it made no difference :(

Waistless
03-12-2019, 11:11 AM
For Trials Rising I use either of the combination of settings for smooth FPS:

Windowed on, In-game Vsync ON, Nvidia Control Panel V-sync set to "Use the 3D application setting"

or

Fullscreen, In-game Vsync OFF, Nvidia Control Panel V-sync set to "On"

In both cases triple buffering should be off, you can also set the maximum pre-rendered frames in the nvidia control panel, to see if that reduces input delay.

It was the same for Fusion as well, either of those combinations seemed to work the best getting rid of stutter. Although Rising has its own unrelated stutter which I believe happens when it does something network related, as I get a stutter when the game loses connection to ubi servers and tells me so in game.

Unfortunately the game just tears a bunch without vsync, but you could look into a gsync/gsync-compatible freesync monitor if you want less input delay while having it look smooth, though I haven't tried one myself yet.

Kektous
03-16-2019, 03:27 PM
I've had issues with the ingame settings of this game, they seem to not always apply properly.

What I suggest you try is go into Documents/TrialsRising/SaveGames/ and open up localconfig with a text editor. On the second line there should be "GPU Vsync", change that to true if it isn't. Save and try it out. Feel free to fiddle around with other settings here too...

If it already was true, right click the file and go to properties, check "Read Only". This will lock it to the values (Just so you can be sure Vsync is actually being applied). You can change them in game but keep in mind that they will revert to whatever they were set to when you put it on Read Only the next time you open your game, so just in case you'd want to change graphics settings along the way keep this in mind.

Also if none of this works, revert the changes so you don't have to worry about it...