View Full Version : Track Progress Resetting

03-04-2019, 02:19 AM
All of my track progress appears to be gone and resetting every time I start the game. It makes me set the brightness and do the intro every time now, and then gives me only the first track. The game saved my level of 55, I have all of my items and currency as well. My track progress was pretty far along, what is going on here?

03-04-2019, 02:38 AM
I've tried uninstalling and reinstalling, still cannot save any progress. Obviously makes the game unplayable at this point, not sure what it is not saving.

03-04-2019, 02:50 AM
Hey R1ckGr1mes is your inventory full when you launch the game? Do you also have all of your leader board times?

03-04-2019, 03:09 AM
I do have all of my inventory items (even the ones I bought in the store), it isn't full though it is at 100/800. My leaderboard time is still there as well for the one track I can see.

03-04-2019, 12:17 PM
Hey thanks for confirming!

Can you make sure that you are running Uplay PC, and the game .exe as admin?

03-04-2019, 07:46 PM
UPlay is running, trialsrising application given administrator access but the game is still not saving anything. Just keep going back to the damn first track, going to want a refund soon. It was working perfectly fine a couple days ago and all of my other Uplay games are working just fine.