PDA

View Full Version : Bugs Found



HolyDuckingShip
03-01-2019, 06:43 PM
Hi there,

I've played the game approx. 40 hours or so and have run into a variety of bugs. Some of these are already known, or have been posted, but I wanted to list everything I've encountered (PC - Steam Version of the game)

1) Game crashes when exiting to desktop - error message received, no other problems, game opens fine afterwards

2) Disconnected from servers upon finishing a track - this happens occasionally and sometimes causes new best time to not appear on the leaderboard. Need to test whether completing the track after reconnecting WITHOUT beating that best time that happened on disconnect will cause the personal best to be recorded to the leaderboard.

3) No longer receive Loot Boxes. This seems to happen once you hit a certain level...others have been reporting the magic number as level 87. I can confirm that I am level 105 or so and haven't received a loot crate in some time even though every time I level up I still receive the message/prompt that I've been awarded a loot crate.

4) Loot Crates sometimes disappear

5) Texture swap/pop in - Sometimes I notice a texture is different and then it changes once sitting there for a sec. Also, this happens a lot when the track first loads

6) Game hiccup/slowdown - Sort of pigging backing of the last point, when the track loads for the first time, I get random freezing and slowdown. This only seems to happen when I first enter a track. Upon restarting it goes away almost 100%.

7) MotoX Finales - Game takes a really long time to load in between...like considerably more than if I were to just load that track independently.

8) MotoX Individual Tracks - Even if you beat your personal best time, if you don't make the cut in the competition, it doesn't count towards your personal best time. This happened to me after getting like a top 50 time on one and then for the next track I tried, my competition was crazy high ranked runs and even though I was beating my personal best by quite a bit, I finished 3rd out of 4 so my time didn't count.

9) Final Challenge (9 stadium finals needed to play) - When I first unlocked this, it showed 9/9 completed, but there wasn't a prompt (A) to play it. Going to the main menu and back into the map seemed to fix it.

10) World Map Chugging - World map hesitates and generally feels kind of clunky and unresponsive at times

Hopefully most of these are already known and being worked on! Looking forward to a patch to address these. Thanks

OfficaFullHigh
03-02-2019, 02:43 AM
I'm adding one more bug if it's ok :)
But i'm playing the UPlay Version, idk if its important.

After getting a crate notification, the crate sometimes disappear into the void... that happened 3-6 times, idk how much exactly. Restart didn't help... Isn't it annoying enough for us, to deal with the sh*tty stickerloot? Now the crates are disappearing

Manujito
03-02-2019, 03:18 AM
The "crate disappearing" bug happened to me too, and more than a few times as I can tell. Annoying to say the least.

As for the list in the first post, I can confirm pretty much 90% of it, and I'm sure the other is legit too.

If I can add one more related to performance, the game has occasional frame drops (slowdowns) during races, and can be REALLY annoying and problematic when it happens during a Platinum run. It often happens also when the race ends, but that's a minor issue.

HolyDuckingShip
03-02-2019, 08:36 AM
What level are you? I noticed after hitting a certain level, I stopped receiving crates. Others have been reporting the same issue, it apparently happens at level 87 I think it was. Perhaps you're experiencing the same thing?

Ubi-Wusky
03-04-2019, 01:56 AM
I'm gonna go through these 1 by 1 if you don't mind :)



1) Game crashes when exiting to desktop - error message received, no other problems, game opens fine afterwards

We got a few reports about this, and it's being investigated as we speak!




2) Disconnected from servers upon finishing a track - this happens occasionally and sometimes causes new best time to not appear on the leaderboard. Need to test whether completing the track after reconnecting WITHOUT beating that best time that happened on disconnect will cause the personal best to be recorded to the leaderboard.

Once you've tested out that second part, please update me on what you find!




3) No longer receive Loot Boxes. This seems to happen once you hit a certain level...others have been reporting the magic number as level 87. I can confirm that I am level 105 or so and haven't received a loot crate in some time even though every time I level up I still receive the message/prompt that I've been awarded a loot crate.

This has been reported and we're looking into it :3




4) Loot Crates sometimes disappear

Could you let me know when they dissapear? For example do you get one but then can't find it afterwards or do you receive items but then when you check your inventory there's nothing there?




5) Texture swap/pop in - Sometimes I notice a texture is different and then it changes once sitting there for a sec. Also, this happens a lot when the track first loads

This could be simply a delay in rendering, but if you can get a video of it happening in action that would be great!




6) Game hiccup/slowdown - Sort of pigging backing of the last point, when the track loads for the first time, I get random freezing and slowdown. This only seems to happen when I first enter a track. Upon restarting it goes away almost 100%.

Same again, if you could grab a video that would be awesome :3




7) MotoX Finales - Game takes a really long time to load in between...like considerably more than if I were to just load that track independently.

Could you try some basic PC troubleshooting (https://support.ubi.com/en-GB/faqs/000025947/Basic-PC-Troubleshooting/), and let me know if that helps at all?




8) MotoX Individual Tracks - Even if you beat your personal best time, if you don't make the cut in the competition, it doesn't count towards your personal best time. This happened to me after getting like a top 50 time on one and then for the next track I tried, my competition was crazy high ranked runs and even though I was beating my personal best by quite a bit, I finished 3rd out of 4 so my time didn't count.

I believe this is also being looked into :)




9) Final Challenge (9 stadium finals needed to play) - When I first unlocked this, it showed 9/9 completed, but there wasn't a prompt (A) to play it. Going to the main menu and back into the map seemed to fix it.

Glad you found a workaround for it! I'll pass that along and see if it's something others have been experiencing or if it's intended to need to be refreshed.




10) World Map Chugging - World map hesitates and generally feels kind of clunky and unresponsive at times

Hopefully most of these are already known and being worked on! Looking forward to a patch to address these. Thanks

Try the PC troubleshooting I linked earlier and see if that improves for that.


Thanks so much for the extensive list!

Mavark
03-04-2019, 06:21 PM
If I may piggy back with a a minor one or two things I've noticed.
1. Changing the colour of either front or rear rim will change both. Meaning you can't have a red front and green rear. Kinda annoying, no biggy though.
2. Sometimes when applying large stickers that wrap abit around either the avatar or the bike the texture will break on the far side and have weird artifact.
2.5 When putting stickers on the Squids bodykit around the two vent holes up front, it really messes with and warps stickers making it quite hard to produce intricate designs.

Like I said, nothing major here, just minor gripes.

HolyDuckingShip
03-12-2019, 07:17 AM
2) Disconnected from servers upon finishing a track - this happens occasionally and sometimes causes new best time to not appear on the leaderboard. Need to test whether completing the track after reconnecting WITHOUT beating that best time that happened on disconnect will cause the personal best to be recorded to the leaderboard.

Once you've tested out that second part, please update me on what you find!

Ok, have an update on this one. I'm going to lay this out in points just to be clear on the issue:

1) Your current personal best let's say it's 1:00
2) You complete the track in 58 seconds, but have the server disconnected issue
3) You replay that track and complete it with a time of 59 seconds

What I was curious of was two things, just completing the track period afterwards would it register your best time: the answer is no. The second was what if you beat the leaderboard time would that cause it to check and post your best time and the answer there is also sadly a no.

Right now with the game being so new, we'll likely be improving times for a while, but if you get that miracle run, it does kind of suck there isn't anyway to get it registered right now it seems.

HolyDuckingShip
03-12-2019, 08:38 AM
So I went and checked out the PC troubleshooting guide and can confirm that none of what was mentioned changed the issues reported in the original thread :(

I'll try to find the motivation to video cap the issues, but my PC is kind of overkill for this game (8700k/32GB RAM/2080ti) so the pop in and stuttering I imagine everyone is experiencing. The texture pop in at the start of a track could almost be like a loading screen issue, where it switches to the gameplay too quickly and didn't finish loading assets or whatever. The stutter on first playthough is honestly the worse of the two as it actually affects gameplay.

Anyway, I'll try to grab some video later of the issues described and post a link for your review--thanks for looking into this stuff and relaying to the dev team!