PDA

View Full Version : Horrendus performance, unresponsive controls, laggy menus, etc.



Hondune
02-22-2019, 10:06 AM
First of my system info

Desktop pc
Windows 10 pro x64
Intel Core i5-6600k @ 3.5ghz, quad core, no integrated graphics, boost clock up to 4.2ghz
16gb ddr4 ram
GTX 970 FTW+ (factory overclocked)

All drivers up to date, uplay, steam, etc. all up to date. Long time fan of the series, have gold medal at least and 0 faults in every single level in every single trials game since trials hd, and played all the flash games before that (not new to this is my point). Trials Fusion runs fine, presumably its the same engine

This is quite literally the worst running game i have ever experienced on pc, which im going to assume is because of a problem somewhere and not just because its ACTUALLY that bad, it cant be, right? My system is capable of running damn near everything ive ever thrown at it at 1080p, max settings, 60fps, with the occasional drops where expected of course. This game however on the LOWEST settings runs at MAYBE 30 fps at best, with frequent drops into the 10s so often that Its absolutely unplayable. I experimented with all of the usual suspects, AO, Post Effects, anti-aliasing, etc. and nothing makes a difference. Every single thing set to off or low, vsync off/on, lower resolution, windowed vs not, etc. all doesnt make a difference, it struggles to have an average fps above 20. Which leads me to believe this is a code/cpu problem and not a graphical one, potentially something throwing errors or background drm nonsense as has happened in the past. 4.2ghz clearly should be plenty for this game

Along with that, and potentially related, the menus are sometimes terribly unresponsive, often times freezing for up to several seconds when switching between tabs or opening/closing something, and other times they run just fine. Again it seams something in the background is causing massive slow downs.

And, again possibly related, the game will just stop responding to any inputs from my xbox controller. It clearly detects it, and sees that it is there (if i use the mouse so the ui shows pc controls, then press a button on the controller all of the in game icons switch to the xbox ones. So its definitely registering the controller) however non of the buttons actually control anything unless i close and relaunch the game or *sometimes* if i just minimize the game and then open it back up again. This has happened numerous times in the menu as well as actually in the game, within just a couple minutes of playing.

Long time fan, would love to continue being one, but if this is an example of how this game actually is then this may just have to be the first Trials game i skip!

WhosOnTheThrone
02-22-2019, 10:33 AM
I find exactly the same, even 720p low suffers random slowdowns.

Win10 x64
8150 @ 4.2ghz
16gb DDR3 1600mhz
2 x GTX780

Ubi-Gumdrops
02-22-2019, 04:57 PM
Hey Hondune, thanks a lot for the extensive report.

In the first instance does this persist without any overclock active on your hardware? The game might also be trying to use the integrated graphics of your CPU, here's how to make sure your dedicated GPU is used (https://support.ubi.com/en-GB/faqs/27100/Switching-to-the-computer-s-dedicated-GPU/).

I'd also recommend performing a clean boot (https://support.ubi.com/en-GB/faqs/000025721) to rule out any conflicts at the software level.

Hondune
02-23-2019, 03:33 AM
I do not have any active overclocking on my hardware, the GPU is just a FTW+ edition from EVGA which is effectively factory overclocked, i have not changed anything from how it was purchased. It runs literally everything else fine so thats not an issue anyways. And as i said my CPU does NOT have integrated graphics, so it isnt that.

I keep my pc very clean when it comes to boot performance. My OS is on a separate ssd and the only thing other than necessary system apps that I allow to run on start is Steam. I also shut my pc down every night.

UbiMorning
02-23-2019, 08:39 PM
@Hondune Could you submit your MSINFO/dxdiag files (https://support.ubi.com/en-US/Faqs/Details/kA030000000emSbCAI?name=how-to-submit-dxdiag-and-msinfo-files) for a further look? Let me know what your ticket number is!