View Full Version : Game breaking beta bug

02-21-2019, 10:37 AM
Tells me i am level 29 in game but says i cant get the viper bike until level 4..
Leaving me unable to do anything in the beta.
Anyone else?

EDIT: Soloution is now found. Credit for the fix goes to the original poster https://forums.ubi.com/showthread.php/2000435-Progress-not-reset-from-closed-beta-and-related(-)-problems?p=13970383&viewfull=1#post13970383
this isnt working for me possibly because i was in a private beta? But it seems to work for most so try it out
Simply disable cloud save
Open uplay
Hit the three blue lines at the top left
Then click that box that says 'Enable cloud sync for all games' this is clicked by default just click again to disable
Then go to documents-Trials rising
And when you see the file that says save files just rename it to something random in my case i changed the name to 'Fix'
this essentially tells it to fix the file,.
Now it should be working.

Solution 2:
iF the above dosent work try deleting the trials world tour folder
If stil not working keep it mind they are working on it i still as i said cant get it work.
Despite doing all the above but it should work for others.

02-21-2019, 10:39 AM
Its basically carried over my level from closed beta breaking the game

02-21-2019, 10:44 AM

02-21-2019, 10:57 AM
Same here my dudes. Level 19 after the closed beta and the two faster bikes which are supposed to be unlocked at levels 4 and 7 are still locked.

My only concern now is that this doesn't carry across to the full game and they actually reset progress upon release.

02-21-2019, 11:02 AM
This problem also means that we can't even attempt the Extreme track as the initial Squid bike cannot be used. Dangit :(

02-21-2019, 11:14 AM
Hi there grcsurfin,

Thank you for reporting this issue. Which platform are you currently playing the Trials Rising Open Beta on?

*Moving this thread to our dedicated Trials Rising Open Beta forums

02-21-2019, 11:31 AM
The problem with this, that we cannot progress through the game. I am at level 23 but all the bike is locked, and of course witch the basic Squid bike the medium tracks kinda hard. I think this issue only affect the players who participated in the closed beta (and as far as I know that was only for PC). Maybe a progression reset would be a solution.


02-21-2019, 12:03 PM
Bug is effecting anyone who playeed closed beta or private betas to the point their level raised ABOVE the level requirments for the rhino/mantis so they wont unlock.
A simple fix would be a progress reset or a simple update to make higher levels above 7 and 4 unlock both bikes at their respective levels.
Also yes a leaderboard wipe IS NEEDED and so is a progress wipe as beta players HAVE BROKEN medal times giving them the max medal for all levels this second bug happeend when you replayed othjer levels.

Please sort this problem out before release.

02-21-2019, 12:33 PM
Hey grcsrfin, in case you haven't seen it there's a solution in the other thread here: https://forums.ubi.com/showthread.php/2000435-Progress-not-reset-from-closed-beta-and-related(-)-problems?p=13970383&viewfull=1#post13970383

Basically disable Uplay cloud saves, delete your local save file, restart the game, reenable cloud saves.

I guess I just assumed progress was handled at Ubi's end for some reason.

02-21-2019, 12:44 PM
Hey grcsurfin,

Has the steps suggested by wholehole solved your issue?

02-21-2019, 02:18 PM
Nm still not working for me but it should work for most.
I think this is because i was in the closed private beta

02-21-2019, 02:29 PM
Thanks for clarifying! You can also move the save file out of your local folder temporarily to generate a new save.

02-21-2019, 02:45 PM
Sadly i stiill cant get it worked.
Keep in mind i was also in the closed private beta.
Deleting files
Disabling cloud sync
Nor nerifying files fixed it for me.

02-21-2019, 02:53 PM
It automatically resotres mmy files.
Not just save files.
I think it might be because as i said i wasnt just in the closed beta.
Problem still persits with my freinds to.

02-21-2019, 07:38 PM
Please follow the steps in our FAQ (https://support.ubi.com/en-GB/Faqs/000040756) for deleting these files. Let me know if that helps.

02-21-2019, 08:42 PM
Automatically adds the save file back in when IN THE game itself as soon as my gamertag is detected by the game.
I think this might of been because i was in a test beta.
Done everything.
No solution works.
Its also for a fact done correctly. https://gyazo.com/ae6ac817367a65baed344a3dd37c97b3

And as soon as i open the game up the files restore itself as soon as i connect to the ubi servers.

02-21-2019, 08:55 PM
I'm sorry to hear that. Are you deleting the save files on the C: drive? Please note that Ubisoft games are saved on the C: drive regardless of where Uplay and Trials Rising are installed.

02-21-2019, 10:39 PM
I'm having the same issue, playing on PC, i was in the closed Beta, i've disabled cloud saves and have tried both deleting all trials folders and files in the C: documents and tried renaming those files and folders but every time i start the game up it loads me back up at level 26 with only the first bike unlocked which means i can't even attempt the extreme track and most other tracks above medium difficulty are impossible for me and my skill level to complete on the beginner bike.

Edit: got it fixed by deleting all trials folders from c:documents, turning off cloud sync and deleting the save files from programs(x86)/uplay etc....

02-22-2019, 06:53 PM
I am glad you were able to resolve it fourftofflame!