PDA

View Full Version : My friend invited me for closed beta, but no email



CasualVictim
01-29-2019, 10:29 PM
So he told me he invited me, but I did not get an e-mail.
I also can't see the thread about this on the forum, since it says I don't have permission According to Google this is the post (https://forums.ubi.com/showthread.php/1985106-Invited-by-a-friend-but-no-email-Check-here!?goto=newpost)

Scania-Lady
01-29-2019, 10:37 PM
try this link: http://betasignup.ubisoft.com/anno1800cb/FriendList/

UbiSnout
01-31-2019, 01:30 AM
Hello,

We have this issue covered here (https://forums.ubi.com/showthread.php/1985106-Invited-by-a-friend-but-no-email-Check-here). Using the provided link should resolve your problem.

Kobiyan
01-31-2019, 02:43 AM
Hello,

I'm also still having an issue with the private beta invitation.

I didn't receive the e-mail, and while opening the url, the new tab closed few seconds after. I had to open it in a new window to prevent the tab to shut down.

It then told me "congratulation, registration successful", but sadly, I still can't download the beta from my uplay launcher.

Best regards.

tellos84
01-31-2019, 07:59 AM
forgot it, it showed up in uplay a minute ago ;)

Puuhbearchen
01-31-2019, 09:32 AM
same problem here... all that I get is:

http://puuh.bplaced.net/Public/displayed.jpg

i tried Firefox (mac and PC), Chrome (mac and PC), Edge, Safari and Safari on my iPhone. Deleted all my caches and cookies. nothing helped.

gilly775
01-31-2019, 04:08 PM
I used Chrome Incognito mode and that worked to register but sadly don't see the beta in my library.

F1Database
01-31-2019, 04:43 PM
Same problem here. No Email received. Registration says successfull, but no beta client available.

Takichi90
01-31-2019, 05:13 PM
Got the Issuse that someone i invited didnt get the "Congrats" Message he only can Register himself and for that he Needs a Code

jildin2205
01-31-2019, 10:44 PM
Same problem as Puuhbaerchen. I only see that message. Already tried different browsers and settigs, but still nothing...

wohnen.ac
02-01-2019, 09:12 PM
I had the same login problem with Firefox version 64.0.2 and Microsoft Edge version 42.17134.1.0 under Windows 10. Then, opening the login page from Internet Explorer version 11.523.17134.0 (available in my case from within Microsoft Edge by clicking on the three dots in the top right corner and then clicking "Open with Internet Explorer") did the trick.