PDA

View Full Version : Left wing of Zenith suddenly not registering?



Splintrshield
12-31-2018, 06:33 PM
We have two ships, two controllers, and when we started playing, in the space above Atlas during the very first mission, the Zenith was working fine, but after we got down to the surface, the left wing of the Zenith just seemed to stop working. It disappeared and even after plugging it in, a few times, nothing was registering. I thought it might be part of the story at first, but on the second playthrough I didn't hear anything about this. Can anything be done?

Thank you for any help you can give!

!Matt Shields

Splintrshield
01-01-2019, 06:57 AM
Never mind, figured it out - I tried plugging it in upside down and on the other side and it suddenly started working again! No worries.

UbiGabrinth
01-02-2019, 10:30 PM
Thanks for letting us know. Please reach back out if you have other issues or if this issue returns.

PaladinV3
05-25-2019, 02:33 AM
Iím having a problem with the right wing on mine and itís plugged in the right way. I can get it showing but I have to tilt my zenith somewhat on the mount to do so and it wonít even stay that way. Not sure if something is wrong with the chip thing on the bottom that gets read but if it is then idk if thereís any way to replace it without having to buy a new starter pack or whatever.

Ubi-Woofer
11-04-2019, 04:40 PM
I’m having a problem with the right wing on mine and it’s plugged in the right way. I can get it showing but I have to tilt my zenith somewhat on the mount to do so and it won’t even stay that way. Not sure if something is wrong with the chip thing on the bottom that gets read but if it is then idk if there’s any way to replace it without having to buy a new starter pack or whatever.

Hey PaladinV3, I do apologise that no response was given to you on this thread until now. Are you still having issues with the right wing of your ship? If so, can you please give these steps (https://support.ubi.com/en-GB/faqs/37790/PS4-Troubleshooting-for-Toys/) a try to try and resolve these issues?

If issues do persist afterward, it may be worth testing an alternative grip / wing if you have a friend or family member who also has the game on the same platform with the same peripherals, to determine if the issue is with the wing itself, or the mount in some regard. If replacement would be necessary following that testing, I'd recommend that you reach out to the retailer from where you purchased the game, as they may be able to assist :) I hope that you get it sorted!