View Full Version : Game won't pass the first loading screen after the last update.

12-07-2018, 05:39 PM
Before any of you guys ask, yeah i tried everything (and lost 1 day) reboot, uninstall, changing settings, this game need a fix patch, i tried a old version and worked, after updated is now stucked in the first loading screen, after waiting a long time the game crash I know this is going to be a bit disrespectful with the devs but I do not care, anyway, "fix your **** Ubisoft".

12-07-2018, 08:07 PM
Hi again henrique120000. I responded on this thread (https://forums.ubi.com/showthread.php/1958509-The-Crew-2-won-t-pass-first-loading-screen) as well, but I was able to find your ticket. Do you happen to have the game installed on an internal or external HDD on your XB1?

12-07-2018, 08:48 PM
internal HD, but like i said, "bug" i can do wathever i want and in the end is the same thing, and another info i installed the game via physical media (tested updated after installed)

12-08-2018, 10:12 PM
If it is a physical copy, are you able to test the game on another Xbox?

12-11-2018, 10:42 PM
problem solved 2 days of gameplay lost but I managed to make up for lost time already getting to RB 14 after many hyper car races, thanks for listening, the game is worth the price it has.

12-12-2018, 08:33 PM
Glad to hear you were able to resolve it!! Enjoy :D