PDA

View Full Version : Anno 1404 Venice freezes



ToySoldier1912
11-30-2018, 01:19 PM
Hello,
After around 1-2 hours ingame or sometimes even quicker, my game freezes suddenly and the hourglass is turning forever.
My spec:
Intel® Core™ i7-8700 Processor
RAM: 16 GB
Graphics: NVIDIA GeForce GTX 1070
Windows 10
I tried using 4GB patch, changing Direct to 9 but none of them seems to help

dmdilks
12-03-2018, 03:09 PM
I too get it once in awhile. There really nothing you can do. The game has been broke from the beginning. The only thing I can say is make sure you are saving the game every 15 mins.

The one thing you can try is make your page memory larger. Because that is how they tried to fix the game with page memory.

Achtarm124
12-07-2018, 12:35 PM
You need to customize both Anno4.exe and Addon.exe for 4 Gb.
However, when building records in Lategame, problems can occur if the whole map is populated.
I don't have any problems, but I can't tell which memory usage = RAM + Pagefile + VRAM, because I never paid attention to it.

dmdilks
12-07-2018, 02:44 PM
I run a i9 motherboard with 32gb of memory, a 8gb video card, 8000/12000 on page memory. I have problems with it freezing & running out of memory too. The game has a memory leak and Ubisoft tried to fix with the page memory. You can try all the little things out there, but nothing will really work because of the memory leak.

Achtarm124
12-07-2018, 04:43 PM
It is true that 1404 has the so-called memory bug since its release. It defused that enormously up to at least 2/3 of the development, after that it did not run optimally, but it worked.
Reduce the automatic saving interval to 15 minutes.
I also have 32 Gb RAM without pagdefile and it runs top,
and next to an oldtimer 6700K a 1080.
If you have overclocked, use the default setting for 1404. With OC there are more possible sources of error.

dmdilks
12-08-2018, 12:29 AM
Here are some things that can help speed up they computers.


1. On Win 7 Right click on My Computer. Then click on properties.

2. On Win 10 you have to right the start button then click on file explorer on the next screen right click “This PC”

3. Click on Advanced System Settings left hand side.

4. Performance - Click on “settings” Tab

5. Visual Effects - Click on Adjust for best performance.
The only thing in the list you want with a check mark is: You need to leave this one with a check mark "Show Thumbnails instead of Icons". That way when you look at your pictures you see them.

6. Click Apply – It will change to the Classic Windows in Win 7 Desktop and that is OK for now.

On win 10 it will not change the desktop. So you will not have to change anything once you get back to the desktop.

7. Click OK, then OK again and then exit out of that screen.

8. Once you are back on the Desktop right click on the screen and click on properties click on Personalize.

9. You see: Change the visuals and sounds on your computer.

10. Under Aero Themes: Chick on the Windows 7. You really need Windows Aero for all the little things to work. Then you can click on the desktop you had under My Themes. It will change and you are done.

11. There is another thing you can do to help is go to "Start button" and type in msconfig then click on msconfig in the box. Once in there you will click on startup tab and in there you can turn things off that are using memory and running in the background at startup.