View Full Version : Can't accept NDA for technical testing, "login error"

11-27-2018, 01:27 PM
Hi, I got an email confirming that I got accepted for the technical test but I just get a "login error" when trying to log in and accept the NDA.
I can't even login to the Anno 1800 website (https://www.ubisoft.com/en-us/game/anno-1800/).
Every other ubisoft site I've tried works and I can obviously sign in here so the password or email isnt wrong.
I sent an email to Ubisoft support last friday (nov 23) but I've not gotten a reply yet.

Is there anything that can be done so I can try the technical test?

11-27-2018, 02:33 PM
I have the same problem :( tried deleting cookies , resenting my password , nothing works :(

11-27-2018, 03:47 PM
Had the same issue; Could logon just fine on Uplay and Ubi account but on that page it gave me a login incorrect.

What worked for me (after having reset my password and turning on two steps verification)
is turning off the "shield of brave" apparently the login on the NDA page and forum uses a different way to logon from the Uplay/Account page.
And with Adblocks/Chrome/Brave it sometimes misbehaves;

I would say give it a try in a different browser - it worked for me.

11-27-2018, 03:53 PM
Hi folks, for those where the NDA Login page doesn't let you login, make sure that you accept cookies from Third Party Websites during the signup.
That should allow the site to work properly.

11-27-2018, 09:11 PM
did you find a work around?

11-28-2018, 01:20 PM
Okay, so after following Letovwestens advice I tried to log in using Internet Explorer and it worked for me.
Not sure why the Anno 1800 site doesnt work using chrome (without adblocker or anything) when every other site works but oh well.

If you have the same problem try using Internet Explorer.