View Full Version : Beta Site for the NDA - Can't log in

11-23-2018, 08:39 PM
Changed my password twice this morning, but still get the message "Login Error!" when I try to log in from the email. Any hints or help to get this going?



11-23-2018, 10:25 PM
Same Problem here. :-(

11-23-2018, 10:40 PM
For me it worked right now. I could sign the NDA. Seem to be no general Problem.

11-23-2018, 10:44 PM
First of all thank you for the technical test invitation. (yay!) Sadly I am running into the same problem.
I tried disabling my addblocker, vpn, changing password but to no avail. Login via https://forums.ubi.com/ gives me no problem (or launcher). But login via the anno union page or the special test invitation page gives me a login error. Previously I was able to login and reply on anno union directly however somewhere along the line this became unavailable.

11-24-2018, 01:58 AM
Hello everyone,

I am reporting this issue, and will keep you updated asap.

11-24-2018, 02:50 AM
Had the same problem in my default browser (Edge). Logged in in Chrome then without problems. After that, i could also log in Edge without problems.

11-24-2018, 09:06 AM
Hey guys I tried it on an old laptop and it worked. I don't know why how or what. But it worked so maybe try it on a different device.

11-24-2018, 01:17 PM
@ Dutch_Paratroop: Yes, You're right. It works on another PC.

11-24-2018, 07:13 PM
try log in with EDGE (not with firefox and chrome)

11-25-2018, 02:15 AM
Hi everyone,

Glad to here that some of you managed to find a solution for this issue. :)
If you are still experiencing problems, please reach out via private message to Ubi-O5 (https://forums.ubi.com/member.php/2335501-Ubi-O5) .

11-25-2018, 02:22 AM
Yup, worked in Edge... Didn't work for me in Chrome. Try a different OS or machine or browser.