View Full Version : (All Digital) I purchased DLC weapons, but they're still locked.

11-22-2018, 12:21 AM
I recently purchased a digital version of Starlink. I played for a while with the included content, then purchased some DLC packs; one including the Nullifier weapon, and one including the Hailstorm and Meteor Mk2 weapons.

I closed the game and allowed the DLC to download. When it was finished downloading, I started the game and had the Nullifier unlocked, but the Hailstorm and Meteor Mk2 were still locked.

I thought that perhaps purchasing multiple DLC at once could have confused the system and only one DLC pack downloaded, so I tried reinstalling the entire game. However, upon getting back into the game, the same issue persisted.

I've revisited the Nintendo eShop and it shows that the weapon pack has been purchased, but the weapons are still locked in-game.


11-22-2018, 09:54 AM
Hey DerpKat,

Did both DLC packs fully download and install? If only one appears in the game, it would suggest the other did not install.


11-22-2018, 04:07 PM
Hey Swaggins,

On the Switch, when DLCs are being downloaded, it doesn't specify the name of the DLC package. So, after purchasing multiple DLCs, then waiting for the download, I wasn't sure if it was downloading all of them, or just one of them.

After disconnecting my Switch from the internet and reconnecting it, the missing DLC downloaded and I can now use all of the weapons that I purchased. I'm not sure if this was the solution, but it worked.

11-22-2018, 11:17 PM
Glad to hear that you now have access to the DLC Weapons DerpKat!

Feel free to get back in touch if you need further help :D