PDA

View Full Version : Settlers VII history edition screen resolution



elydogs1973
11-16-2018, 04:01 PM
I have just installed the new history edition of settlers vii on windows 10 and I cannot set the resolution higher than 1280 x 800. I game at 1080p. Does anyone have any ideas. I did have the old one installed which I had problems with.

Ubi-Gumdrops
11-16-2018, 04:10 PM
Hey elydogs1973!

Thanks for the heads up. Can you try running Uplay PC as Administrator in the first instance?

elydogs1973
11-16-2018, 04:21 PM
Hi Ubi-Gumdrops

Just tried that and I still cannot go above 1280 x 800. I have an Nvidia GTX 1070 running 416.34 drivers

Ubi-Gumdrops
11-16-2018, 04:26 PM
Thanks for checking. The latest Nvidia drivers are 461.94 - can you please try updating?

elydogs1973
11-16-2018, 05:05 PM
Hi I have just updated and they have made no difference. I am going to reinstall and see whether that does anything. I will let you know

elydogs1973
11-16-2018, 06:11 PM
Well I have reinstalled and that did not help

elydogs1973
11-16-2018, 06:13 PM
I found the options configuration file and manually set the resolution and it worked that way, odd that I had to do that though

Draconarache
11-16-2018, 06:17 PM
The Settlers 7 original bug ^^

https://support.ubi.com/en-Gb/Faqs/000032846/Changing-the-resolution-in-The-Settlers-7

elydogs1973
11-16-2018, 07:05 PM
Thanks for that, ironically I dont remember having this issue on the original version. Unless my memory has faded of course

Ubi-Gumdrops
11-17-2018, 09:12 AM
Thanks for the assist Draconarache!

Glad to hear you're all sorted elydogs1973 - let me know if you encounter any other issues :)

alex haden
11-17-2018, 10:56 AM
** UPDATE** ok, i was being silly. Be aware, if you have had S7 installed before you will have a S7 and a S7 History Edition folder in your documents - make sure you change the one for the history edition, as if you change the other one, it doesnt do anything lol

Off to stand in the corner with my D hat on.........




Am getting the same, tried to change the settings in the .ini file to my 2560x1440, and it still says 1080 and looks blurry - its clear its not the native res of my monitor.

Everytime i try and change in the game, it goes to some random half screen messy setting where i cannot actually click on anything :-(

Any ideas, bought the collection specifically for this, and its disappointing to find its no better than the original.

Ubi-Gumdrops
11-17-2018, 12:13 PM
Hey again Alex :)

Don't worry it happens to the best of us!

Marty12887
11-17-2018, 12:34 PM
Its the original bug from the game. Only work around is to open the options.ini in notepad and manually enter your screen resolution

mr_hawn
11-17-2018, 02:34 PM
I'm also having an issue with game resolution in Settlers 7 History edition.

I changed to my native 3440x1440 resolution in the .ini file, but when I start the campaign it downgrades the resolution back to 1024p.

Ubi-Gumdrops
11-17-2018, 03:09 PM
Hey mr_hawn - can you try any other resolutions?

mr_hawn
11-17-2018, 03:58 PM
25601440 resets the resolution to 1280x800 when Bors video plays and it will also carry on to the game. (I made a mistake in the first post it wasn't 1024p)
1920x1080 works, and the image is stretched where 2560x1440 was letter-boxed with black bars on the sides.

Marty12887
11-17-2018, 05:15 PM
If the rest of your settings are as you want them change the resolution in the options.ini file then change the file to read only.

That should stop the game from changing your resolution as it cant change the information in the file. However it might crash the game if it really doesnt like it.

mr_hawn
11-19-2018, 11:29 AM
Such a clever idea, I can't believe it worked. If I open the settings menu it will crash the game.
I can play now with a full 3440x1440 resolution.
I hope they update the title with fixes, so I don't have to worry about crashes.