View Full Version : [RESOLVED] Cryogenic Trophy glitched?

10-24-2018, 10:11 PM

I've been playing Starlink: Battle for Atlas for over a week now and did pretty much everything there is to do. So I'm currently mopping up missed Trophies, but I noticed there is something probably wrong with the Cryogenic Trophy. Whatever I do, I can't get it to pop.

I've combined multiple weapons (with one freeze weapon) to shoot and destroy frozen enemies, but it doesn't work. I also tried to fly trough frozen enemies with the boost on my ship, doesn't work either. I've been trying for a few days now, but whatever I do, nothing works.

The strange thing is, my girlfriend - who's playing on her own account - did get the Trophy without specifically going for it. At this moment, I'm out of options and a 98% Trophy progressbar doesn't really look nice. So maybe someone can help me?

I suspect the Trophy can ocassionally be glitched which in my case make sense. Or I just completely missed the way to go, but that seems a bit farfetched since I've used every weapon combined with an Ice weapon (I have the Digital Deluxe Edition).

Anyway, if this is the wrong department of the forum, I'm sorry for any inconvience. Looking forward to a possible solution :)

10-28-2018, 03:35 PM

I've not seen other reports of this not working correctly.

Just to confirm, are you shattering them or do they just die normally? Can you get a video of this, as this will help us to take a look at it?

10-29-2018, 12:00 PM

Thanks for getting back to me. I usually shoot the enemies until they are frozen with just a little bit life left on their healthbar and after that I shatter them with weapons. I also did try to fly through them, but nothing works. I will try to make a video later today or tomorrow.

10-29-2018, 03:35 PM
Thanks for the update.

I shall await your video :)

10-30-2018, 04:56 PM
Hi all,

I just played the game for 10 minutes to make the video and hereby an example. The way I play in this video is the way I tried it with more or less every weapon available or with weapons that made sense in regards to this trophy.

Some of the enemies die instantly via the first shot, but some of them I specificly shoot with the second weapon. I believe that is the basic condition to get this Trophy. I also tried to fly through them, but like I said in my previous post, nothing works.

Maybe the video shows I do something completely wrong, but I don't know any other way to get it. I tried to do it on easy, normal and hard by the way.

If you need some more info, just let me know :)


11-03-2018, 12:02 AM
Please try continuing to fire the freezing missiles as you shoot with your other weapon.

11-07-2018, 02:04 AM
I've done that over 100 times, but that doesn't do it for my either. I also did that before I posted my message on this forum. Any other solution available? I'm thinking to delete everything and reinstall the game to try it with a clean install/save. Maybe that works?

11-07-2018, 12:30 PM
This is a specific status effect you're trying to trigger, have you tried using the elemental barrels scattered over Atlas? :D

11-07-2018, 05:25 PM
No, I didn't. Or at least, I didn't try it for this Trophy. I suppose I need Ice barrels to make it work? Or can I just freeze enemies and throw a barrel at them instead? Thanks :)

11-08-2018, 09:39 AM
Yeah I recommend giving the ice barrels a go! The enemies should be frozen solid and you'll see a 'SHATTER' status effect when you destroy them!

11-08-2018, 07:49 PM
Thanks, I'll try that this weekend :)

11-09-2018, 09:39 AM
No problem! Let us know if you're still having issues!

11-13-2018, 12:34 PM
After throwing two canisters the Trophy popped, so I already was at three 'shatters' apparently. Anyway, I got the Trophy and the Platinum Trophy :) Thanks for all the help, really appreciate it!

11-13-2018, 02:16 PM
Nice shattering, SYPHLED01!
Glad you managed to get it, you make a fine Starlink Pilot! :cool: