View Full Version : Unable to reach Ubisoft Network

10-19-2018, 06:32 PM

I recently bought Starlink on Switch. Everytime I try to link my switch to my Ubi club account it says Unable to reach Ubisoft network.

Is there anything I can do to fix this ?

10-19-2018, 06:51 PM
I am having the same issue on my switch. Timeout with an error: unable to reach Ubisoft servers or something to that effect.

10-19-2018, 07:20 PM
I also am getting a "unable to reach Ubisoft network" when I try to link my account on nintindo switch

10-19-2018, 07:42 PM
Same issue here....
Can someone at ubisoft do something...
Silly to have issues connecting for 2 days now.

10-20-2018, 02:48 AM
VonSparrow I see that you have successfully linked your Ubisoft account and your Switch account. Was there a specific set of steps you took that helped you do this?

10-20-2018, 02:57 AM
Just got home and tried again and it worked! I didnít do anything different, could have been an overload or something.

10-20-2018, 02:17 PM
Glad to hear that, Bahamut_Fire

Thanks for the update!

10-21-2018, 11:06 PM
I just tried at a later time and it worked.