PDA

View Full Version : Random Xbox One X Controller Disconnects?



BARD00N
10-16-2018, 03:10 AM
I know this might be an odd one but I'm getting random Xbox One Controller disconnects on Assassin's Creed Odyssey. I have patch 1.03 and I've tried several work-arounds but the problem is still occurring. It ONLY happens with AC Odyssey and I'm using first-party Microsoft controllers.

I have an Xbox One X and have never had this problem before with any other game. I've got all the latest Xbox Updates and my controllers' firmware was updated as well. About every 10-20 minutes (sometimes a little longer or shorter), the controller randomly disconnects. I thought it was my batteries and changed them out for a fresh pair and still was having the same issues (verified that the Xbox recognized the batteries as full). I then thought it was my actual controller so I busted out a brand new one and still having issues. I don't have many Bluetooth devices, but even tried turning them off to see if that was "bothering" the wireless connection. Still occurs.

Anyone else encountering this? Any other suggested work-arounds?

BARD00N
10-16-2018, 03:18 AM
I have 1.03 listed on my screen (with the phantom 1.04 that was applied).

Additionally, sometimes the controller reconnects on its own...sometimes I have to do it manually. It's a very odd one...

ubi--unicorn
10-16-2018, 05:26 PM
Hey BARD00N, can you please try clearing the cache on your Xbox? To do this, unplug the Xbox for two minutes. Let me know if that helps.

BARD00N
10-17-2018, 02:35 AM
Hey ubi--unicorn, thanks for the reply.

I tried clearing the cash last evening. I didn't have any issues for an hour of remaining gameplay and then turned off my Xbox for the evening (full power down). I turned it on today to play some more and within about 15 minutes (in the pause menu), I had another disconnect.

It happens somewhat randomly...either during actual game-play or in any of the menus. So it's not confined to one area of the game.

BARD00N
10-17-2018, 02:38 AM
I also wanted to add I have the game on the Xbox One X's internal memory, not an external HDD

BARD00N
10-19-2018, 08:49 PM
Still getting controller disconnects even after a reinstall.

Last night I played for about an hour and then got three random disconnects during the "Kingfisher & Robin" cinematic. They all happened basically within a row.

Playing today, I once again about 2-3 disconnects right in a row while exploring, followed by one additional one 5 minutes later.

I'm not plagued by some of the other issues (rather than minor micro-freezes and some resource items spawning in walls and/or unable to be picked up ...mostly the iron metal on the cave walls), the controller disconnects are my biggest issue I have with the game.

Once again, Xbox is up-to-date as is controller firmware...the game is on my internal HDD. This is the only game I have issues like this with so I strongly believe it's tied to the game itself unfortunately.

dragonking1201
11-13-2018, 07:36 PM
Hey BARD00N, looks like I am having the same issue you are having now. I am also on the Xbox One X and I am not sure how this started happening. I am about 60 hours in so far and have not had any issues until now. For me, it looks like it happens mostly during gameplay and cutscenes. Sometimes it also happens in the means. Hope they can find a fix.