View Full Version : Doing time quest bug

10-14-2018, 12:34 PM
After completing the conversation with Deimos & the cutscenes I have no quest to continue my odyssey I tried going to perikles house Sokrates wonít start the cutscene the uprising questline is gone from my quests & I canít progress itís very annoying as Iíve gotten really stuck into the story & canít continue it Iíve tried going back to a previous save but it hasnít work Iíve deleted saves reset my Xbox redownloaded the game no luck any advice has anyone experienced this & know how to fix it

10-15-2018, 03:27 AM
Having the same issue, thought progressing further in other odyessey quests would trigger/fix it, but no luck as now I've beaten the main story. Rather frustrating to say the least. Any assistance would be much appreciated!

10-15-2018, 04:55 AM
I'm also stuck on a quest. Lvl 50 and I can't beat the game. Disappointing

12-18-2018, 07:11 PM
nothing ever fixed this?

12-30-2018, 01:57 AM
Hey there! Can you provide a video of this issue by chance?